Ispconfig 3 nginx Let's Encrypt connection not totally secure

Discussion in 'ISPConfig 3 Priority Support' started by virk6, Dec 5, 2019.

  1. virk6

    virk6 New Member HowtoForge Supporter

    Hello,
    I regenerate in the interface ispconfig the certificate Let's Encrypt for a given domain tototiti.com but I still have the message certificate valid but connection not totally secure;
    What's the problem ?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    https://www.howtoforge.com/community/threads/lets-encrypt-error-faq.74179/
    Also, looks like the connection to that site does not work.
    Code:
    ping -c 3 tototiti.com
    PING tototiti.com (69.172.201.153) 56(84) bytes of data.
    
    --- tototiti.com ping statistics ---
    3 packets transmitted, 0 received, 100% packet loss, time 2054ms
    
    I tried checking with SSL Checker website, can not check since the site does not answer.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make a screenshot of the browser message and post it. Not totally secure might mean that you have a mixed content problem, e.g. some images, stylesheets or js files are loaded from http instead of https, so the ssl cert is valid but some settings in the cms of that website are wrong.
     
  4. virk6

    virk6 New Member HowtoForge Supporter

    Thanks Taleman, i am going to check the link ..
     
  5. virk6

    virk6 New Member HowtoForge Supporter

    Hello,

    Here is my ping result ping -c 3 tototiti.com

    ping -c 3 tototiti.com
    PING tototiti.com (xx.xx.xx.xx) 56(84) bytes of data.
    64 bytes from xx.xx.xx.xx (xx.xx.xx.xx): icmp_seq=1 ttl=64 time=0.049 ms
    64 bytes from xx.xx.xx.xx (xx.xx.xx.xx): icmp_seq=2 ttl=64 time=0.039 ms
    64 bytes from xx.xx.xx.xx (xx.xx.xx.xx): icmp_seq=3 ttl=64 time=0.040 ms

    --- tototiti.com ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2048ms
    rtt min/avg/max/mdev = 0.039/0.042/0.049/0.008 ms
    .........................................


    Here is what i get

    in my /var/log/letsencrypt]# grep "my-domaine.com" let*

    letsencrypt.log.112:2019-12-05 10:34:28,315:DEBUG:certbot.main:Arguments: ['-n', '--text', '--agree-tos', '--expand', '--authenticator', 'webroot', '--server', 'https://acme-v01.api.letsencrypt.org/directory', '--rsa-key-size', '4096', '--email', '[email protected]', '--domains', 'my-domaine.com', '--domains', 'www.my-domaine.com', '--webroot-path', '/usr/local/ispconfig/interface/acme']
    letsencrypt.log.13:2019-12-05 11:15:14,392:DEBUG:certbot.main:Arguments: ['-n', '--text', '--agree-tos', '--expand', '--authenticator', 'webroot', '--server', 'https://acme-v01.api.letsencrypt.org/directory', '--rsa-key-size', '4096', '--email', '[email protected]', '--domains', 'my-domaine.com', '--domains', 'www.my-domaine.com', '--webroot-path', '/usr/local/ispconfig/interface/acme']
    letsencrypt.log.63:2019-12-05 11:04:23,501:DEBUG:certbot.main:Arguments: ['-n', '--text', '--agree-tos', '--expand', '--authenticator', 'webroot', '--server', 'https://acme-v01.api.letsencrypt.org/directory', '--rsa-key-size', '4096', '--email', '[email protected]', '--domains', 'my-domaine.com', '--domains', 'www.my-domaine.com', '--webroot-path', '/usr/local/ispconfig/interface/acme']
     
    Last edited: Dec 5, 2019
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    I guess there is nothing wrong with your cert.
    You just might have included http links to images etc on your https site.
     
  7. virk6

    virk6 New Member HowtoForge Supporter


    Here is the screenshot
     

    Attached Files:

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, that's what I guessed, at least if I translated it correctly with my very limited french language knowledge. So there is no problem with your SSL certs, its just that some images or css files or js files inside that website are loaded over http instead of https. That's something that you must fix in the website files or website cms and not in the server config. If it's e.g. a wordpress site, then you might have not changed the wevsite url to https:// in weordpress settings.
     
  9. virk6

    virk6 New Member HowtoForge Supporter

    Thanks you all for sugestions.
    I am going to check all http remaining in the site and try to replace with https.
    I would let you know ..
     
  10. virk6

    virk6 New Member HowtoForge Supporter

    I'm sorry, the problem is related to a wordpress plugin; I uninstalled it and the problem is fixed.
    Thank you all for all your advice.
     
    till likes this.

Share This Page