Ispconfig 3, Nginx and wordpress permalinks

Discussion in 'Installation/Configuration' started by RobMorin, Sep 24, 2013.

  1. RobMorin

    RobMorin New Member

    Hello, I recently installed the latest ispconfig in a multi server environment. All is working just perfectly! However i am not to familiar with niginx configs.

    I have an issue with a wordpress user who's permalinks are not working..
    IE; rather than

    I know in Apache its done with mod_rewrite and a .htaccess file, but there is no .htaccess support in nginx

    So rather than see the contact page we get a 404 error.

    I googled around looking for answers before posting, and found a few things to resolve the issues but ispconfig in ngnx is different from the examples i saw

    I tried adding the below... to the options tab with in the users account in ispconfig and it did not work

    location / {
    try_files $uri $uri/ /index.php?q=$uri&$args;
    # Add trailing slash to */wp-admin requests.
    rewrite /wp-admin$ $scheme://$host$uri/ permanent;

    What happens is rather than send it to contact or even a 404 it just goes to the home page.

    Any suggestions?

    Thanks to all...

    Montreal, Canada

Share This Page