Ispconfig 3 mysql user problem

Discussion in 'General' started by asovanek, Jun 19, 2013.

  1. asovanek

    asovanek New Member

    I created a database user, and after login through phpmyadmin with root access I couldn't find new user created. I found the user in table of ispconfig database but it didn't creat a mysql user. Some help pls ? :)

    Best regards,

    Andrej Sovanek
  2. asovanek

    asovanek New Member

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that the mysql root user password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is correct.
  4. asovanek

    asovanek New Member

    It's correct. It creates database all fine.
  5. jokerdes

    jokerdes New Member

    same problem

    same problem for me.(ispconfig
    root password is correct in mysql_clientdb.conf.
    does not create any mysql user or database.
    georgios76 likes this.
  6. georgios76

    georgios76 New Member

    I have the same problem
  7. georgios76

    georgios76 New Member


    I am working on ISP Config 3 till 3 weeks. I have installed ISP Config 3 on 2 machines. I have my procedure to install it for NGINX/PHP5FPM.

    Today I am installing on a new VM a DEBIAN 8 / NGINX / PHP5FPM and Mysql server.

    I am connecting fine on my page https:/ /myserver : 8080/ then login fine.

    The problem is that when I create a "DB User" on "Sites" the user is never created.

    I have done the configuration a lot of times since last 3 weeks. Today I reinstall 3 times my Debian 8 but I cannot understand where is the problem.
    I am sure of my Mysql Root password.

    I check it also here: cat /usr/local/ispconfig/server/lib/mysql_clientdb.conf this is good, when i Copy paste my password, I can enter fine in my phpmyadmin page.

    is it something doing with Debian update? where can i find the problem that my DB User is never created?
    I can see my new db mysql user in "ISPConfig" in "Database users" but never created on the mysqlserver and I cant see my user in "Database" when creating a new database.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This happens when ISPConfig is not able to access the database as root user. Did you enter the username "root" and the password of the mysql root user during ispconfig installation when the installer asked for the mysql root details? ISPConfig has 2 mysql users, one for the normal use to access the dbispconfig database and it has the root login stored in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf, this login is used to create new databases only.
  9. georgios76

    georgios76 New Member

    Hello till. thanks for your message.

    I have enter the "root" password only. (i have done 10 times the installation, and 3 times this morning on VMs).

    Fo your information:

    MySQL server hostname[localhost]:
    MySQL root username[root]:
    MySQL root password[]: I put text only here where I put password only Here (in the other (nothing)
    MySQL database tocreate[dbispconfig]:
    MySQL charset[utf8]:
    The next two questions are about the internal ISPConfig database user andpassword.
    It isrecommended toaccept the defaults which are'ispconfig'asusername andarandom password.
    Ifyou useadifferent password,useonly numbers andchars forthe password.
    ISPConfig mysql database username[ispconfig]:
    ISPConfig mysql database password[437da0f1XXXXXXXXXXXXX]:

    My :
    [email protected]:/home/supadm# cat /usr/local/ispconfig/server/lib/mysql_clientdb.conf

    $clientdb_host = 'localhost';
    $clientdb_user = 'root';
    $clientdb_password = 'PASSSWORD';

    I can connect fine on mysql with my "password" from here and I can see the "ispconfig table".

    Should I reinstall another 4th time with entering "root" for username....?

    I am a little :( I cannot understand why I can not create DB user from Ispconfig Panel.

    many thanks
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    No. When the password is correct there, then that's not the issue.

    Se here on how to debug a server:

    1) Disable the cronjob and enable debug level.
    2) Create a new database in ispconfig.
    3) run on the shell and check the output to se why it cant create the database.
  11. georgios76

    georgios76 New Member

    I did what you suggest to me.

    I try to create a db user, no one has been created, I try to created DB, MY DB is Created without "user" linked in Ispconfig, I can see my DB in Phpmyadmin but no users.

    18.12.2015-16:23 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    18.12.2015-16:23 - DEBUG - Found 2 changes, starting update process.
    18.12.2015-16:23 - DEBUG - Calling function 'db_user_insert' from plugin 'mysql_clientdb_plugin' raised by event 'database_user_insert'.
    18.12.2015-16:23 - DEBUG - Processed datalog_id 13
    18.12.2015-16:23 - DEBUG - Calling function 'db_insert' from plugin 'mysql_clientdb_plugin' raised by event 'database_insert'.
    18.12.2015-16:23 - DEBUG - Created MySQL database: c0databasetest
    18.12.2015-16:23 - DEBUG - Processed datalog_id 14
    18.12.2015-16:23 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock

    please find enclosed the log also. I have some problem with "Unlinked OID".

    many thanks

    Attached Files:

    Last edited: Dec 18, 2015
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    The snmp errors dont matter, just run:

    apt-get remove php5-snmp

    as the mdule is not needed. Regarding database error, does the mysql root user has really all permissions to create new users on your server, check e.g. with phpmyadmin. And does your mysql root password has any special chars that might cause problems?
  13. georgios76

    georgios76 New Member

    ok for php5-snmp.

    my Mysql Password contains '%' and '@' as specials characters. (and it is the same as other root password on other vm)

    I can create through phpmyadmin a new DB and I can also create a new user.
    the problem remain on the creation of the user through my IspConfig3.
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you create a db in ispconfg where you assigned that user to? A mysql user gets added at the time point when you add a database that uses this user and not when you add the user in ispconfig.
  15. georgios76

    georgios76 New Member

    I created 2 test db in Ispconfig, but it is never attached a user in Ispconfig. -> I cant assign user because there are never "users" loaded in the list but you can see the users at the screenshot, they never have been created in Mysql.
    I created 6 mysql user in Ispconfig but they never created in mysql.

    I created on db through phpmyadmin name "test" and a user named "testx" with root login to test it.

    please find the screenshot

    Attached Files:

  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so your system is working properly. When you did not assign a user then it can not exist in mysql, unused mysql users dont get created as ispconfig is a multiserver system and it is not clear on why server a mysql user is needed before the database is created and beside that, it makes no sense to add unused mysql users.

    Your problem is that you missed to assign a user to the database. The list will show all database users in the database form that belong to the same client, so when you add a database user for client 1 and then add a database for client 2, then no user will sow up in the list off course. The database user and the database have to belong to the same client.
  17. georgios76

    georgios76 New Member

    Clearly, I am a little bit confused. I created one Client.
    On this Client, I would like to created different "websites" and also different "mysql user", for example right now, I can't load my "db users" as you see in my screenshot.

    1) i created 3 differents test user for a client.
    2) they are never loaded through the Database (add)

    Attached Files:

  18. till

    till Super Moderator Staff Member ISPConfig Developer

    This means that the DB users that you created dont belong to this client. Check the DB user, it has a select field where you select the client to that this user belongs.
  19. georgios76

    georgios76 New Member

    I feell sorry, I did not understand why I did not check this setting.

    I miss to put the "CLIENT" on the "WebSite", I apologize !

    Sometimes, we go very fast and we missed some important step, finally my DB Users automated created after 1 min,

    is it exactly a time when creating a db or user or something else for the CRON?

    many thanks for your support Till,

    have a wonderful day,
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig cronjobs runs once a minute and it will do all ending tasks then, a DB user will get created when you add a DB that uses this user as adding a user with permission to access nothing makes not much sense, therefore the user gets added at the same time when the first db gets added where this user has access for,

Share This Page