IspConfig 3 Mysql remote user not working

Discussion in 'General' started by atento, Jan 15, 2014.

  1. atento

    atento New Member

    I use ispconfig 3 for more than 2 years, the mysql permissions are missmatch again, doest work anymore only works on localhost.
    Yes the 127.0.0.1 line is #
    I know maybe this is a nice feature to add to the "5€ book".
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Not quite sure which ispconfig version you use, but in 3.0.5.3 the mysql prmissions for local and external databases are working fine. Just verified this on my cluster by adding a new database and database user.
     
  3. atento

    atento New Member

    is the last version.

    Is the last version.
    Ok on my "cluster" ispconfig dont add the [email protected]% and then i cant connect from remote.
    Your cluster adds the % or is non feature ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you select the website to which the database belongs in the database settings? If yes, then ispconfig adds by default access from localhost and from the hostname / ip address f the node that hosts the website. In case you want to have access from everywhere (not only the webserver node and localhost), then enable the "remote access" checkbox in database settings, this adds access from %.
     
  5. atento

    atento New Member

    Not working

    Yes i select the website, i made a fresh install yesterday.
    Is not on 1 install i have multiple servers and all with the same problem, i normaly just add the permisson manualy in phpmyadmin.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. I'll ask the maintainer of the mysql plugin, maybe he can give you some additional hinst what might gone wrong here.
     
  7. atento

    atento New Member

    the only diference

    The only diference is that i only comment the 127.0.0.1 for the first time when i need to connect to that server remotly, i create all the databases..domains...dns.first..
    I cant see any other diference on my install.
    And yes i restart mysql when i make the 127.0.0.1 comment.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    yYou mean the inet interfaces line in my.cnf file? or in the ispconfig code?
     
  9. atento

    atento New Member

    Is ok now

    Sorry is ok now reboot and removed and added again, worked ok.
    thank you.
     
  10. atento

    atento New Member

    in the my.cnf file

    i mean the inet interfaces line in my.cnf
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    ah ok, then I misunderstood you, sorry. Thought there was a issue in the way ispconfig adds the mysql users.
     

Share This Page