ISPConfig 3 - multiserver setup: gmail mark emails as spam

Discussion in 'General' started by Feri, Sep 13, 2016.

  1. Feri

    Feri New Member

    Hello everybody!

    I have a multi-server setup, where is the Webserver are on the machine1 and the MTA is on the machine2.
    Roundcube is deployed on the machine1, it uses directly the machine2 as SMTP.
    But, when i send a mail from Roundcube or desktop clients over the machine2, gmail mark the e-mails as spam.

    I have the DKIM, spf configured on the domain, but it is still spam.
    I have no more idea, why make this mistake. Somebody else maybe?

    Thank You!

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Check the dns of the hostname and ensure that the hostname of the server is set also as hostname in postfix
    2) Check the reverse dns record of your IP, it must match the hostname.
    3) Check that your server IP is not on any blacklists.
  3. Feri

    Feri New Member

    1) It is equal.
    2) It is match.
    3) It is a fresh IP, but i already checked it, and did not listed.

    So, the domain is The Webserver is, and the mail server is
    I tested on more receiver mail servers (with assp proxy, Oiffce365), only gmail mark as spam of any sender from this domain.

    Thank You!

  4. Jesse Norell

    Jesse Norell Active Member

    What do the message headers look like on a message coming via roundcube -> mail server -> somewhere? Check if there is an "Authenticated sender: [email protected]" added in the Received headers, and if not, make sure roundcube is sending authenticated with:
    $config['smtp_user'] = '%u';
    $config['smtp_pass'] = '%p';
    And that postfix is adding that to the Received header (smtpd_sasl_authenticated_header=yes)
  5. kerrsmith

    kerrsmith Member

    You could try using the following email checker service - it will show you any issues it sees with your mails so might be worth a quick check to see what it says:

Share This Page