ISPConfig 3 move to another server

Discussion in 'Installation/Configuration' started by rputnins, Dec 8, 2009.

  1. ikrudolf

    ikrudolf Member

  2. abintipl

    abintipl Member

  3. urgensherpa

    urgensherpa New Member

    ispconfig 3 migration

    it worked for me , i migrated from centos 6.5 to centos 6.5 ,
    + i also had to copy/paste [scp] the /usr/local/ispconfig directory from old to new server besides other steps.
    good luck!
     
  4. abintipl

    abintipl Member

    Server Migration with Email Issues

    Hi,

    Thank you for your advice.

    All my sites & other stuff migrated from Old (Master & Slave) servers to New Server ( Only One Server) went okay.

    I can Import the Database, can run all my sites BUT ISSUE is Emails, which are not being sent or received

    I thoroughly spent many hours on forum posts searching for solution t but could not solve my issue

    OUTPUT of my 'Show Mail Queue"

    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    E6396D20D53 20512 Thu Aug 28 13:59:54 [email protected]
    (host 127.0.0.1[127.0.0.1] said: 421 4.3.2 Service shutting down, closing channel (in reply to RCPT TO command))
    [email protected]

    E0A87D20CED 971 Thu Aug 28 01:39:01 [email protected]
    (host 127.0.0.1[127.0.0.1] said: 421 4.3.2 Service shutting down, closing channel (in reply to RCPT TO command))

    OUTPUT of my 'Show Mail Log"

    Aug 28 14:43:58 vps2 postfix/error[3183]: 5666CD20CCD: to=<[email protected]>, orig_to=<root>, relay=none, delay=75898, delays=75897/0.43/0/0.14, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending DATA command)
    Aug 28 14:43:58 vps2 postfix/smtp[3172]: 9BDC7D20D37: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=8819, delays=8819/0.2/0.24/0.13, dsn=4.3.2, status=deferred (host 127.0.0.1[127.0.0.1] said: 421 4.3.2 Service shutting down, closing channel (in reply to RCPT TO command))
    Aug 28 14:43:58 vps2 postfix/error[3181]: 032A0D20C88: to=<[email protected]>, relay=none, delay=111837, delays=111836/0.43/0/0.15, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with 127.0.0.1[127.0.0.1] while sending DATA command)
    Aug 28 14:45:01 vps2 dovecot: pop3-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
    Aug 28 14:45:01 vps2 dovecot: imap-login: Disconnected (no auth attempts): rip=::1, lip=::1, secured
    Aug 28 14:45:01 vps2 postfix/smtpd[3261]: connect from localhost[::1]
    Aug 28 14:45:01 vps2 postfix/smtpd[3261]: lost connection after CONNECT from localhost[::1]
    Aug 28 14:45:01 vps2 postfix/smtpd[3261]: disconnect from localhost[::1]
    Aug 28 14:47:18 vps2 postfix/scache[3175]: statistics: start interval Aug 28 14:43:58
    Aug 28 14:47:18 vps2 postfix/scache[3175]: statistics: domain lookup hits=0 miss=2 success=0%
    Aug 28 14:47:18 vps2 postfix/scache[3175]: statistics: address lookup hits=0 miss=2 success=0%

    OUTPUT of my 'Show Mail Warn-log"

    Aug 28 14:18:58 vps2 amavis[2130]: (02130-01) (!)Requesting process rundown after fatal error
    Aug 28 14:20:48 vps2 postfix/smtpd[2206]: warning: 113.56.248.201: address not listed for hostname 113.56.arpa.hb.cnc.cn
    Aug 28 14:23:58 vps2 amavis[2134]: (02134-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;port=3306': Access denied for user 'ispconfig'@'localhost' (using password: YES)
    Aug 28 14:23:58 vps2 amavis[2134]: (02134-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 103) line 241, <GEN32> line 4.
    Aug 28 14:23:58 vps2 amavis[2134]: (02134-01) (!)Requesting process rundown after fatal error
    Aug 28 14:23:58 vps2 amavis[2135]: (02135-01) (!)connect_to_sql: unable to connect to DSN '
    Aug 28 14:23:58 vps2 amavis[2341]: (02341-01) (!)connect_to_sql: unable to connect to DSN 'DBI:mysql:database=dbispconfig;host=127.0.0.1;port=3306': Access denied for user 'ispconfig'@'localhost' (using password: YES)
    Aug 28 14:23:58 vps2 amavis[2341]: (02341-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 103) line 241, <GEN32> line 5.

    OUTPUT of my 'Show Mail Error-log"
    Aug 28 12:50:09 vps2 amavis[29759]: (29759-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 103) line 241, <GEN32> line 5.
    Aug 28 12:50:09 vps2 amavis[29964]: (29964-01) (!!)TROUBLE in process_request: connect_to_sql: unable to connect to any dataset at (eval 103) line 241, <GEN32> line 4.

    I have already run
    /etc/init.d/apache2 restart
    /etc/init.d/amavis restart
    /etc/init.d/postfix restart
    /etc/init.d/freshcalm restart

    Further, PLEASE NOTE MY OLD Server Installation was based on 2 Servers
    http://www.howtoforge.com/how-to-run...debian-squeeze

    This New Server is Single Server

    I am missing some Slave Server Settings which was on OLD installation whereas on this I have already deleted Slave Server from System > Server Services

    I would really request for an immediate Help

    Thanks & regards,

    Abin
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Just a guess, you have either overwritten the password of the mysql ispconfig user in mysql or you replaced the postfix and dovecot config files on the new server with the ones of the old server. to fix your setup, download ispconfig, unpack it and run the update.php script on both servers and choose to reconfigure services.
     
  6. abintipl

    abintipl Member

    Mail Problem

    Dear Sir,

    Thank you for your quick reply and it did work for me.

    BUT one particular Domain for which I am using Google MX throws an
    Error "loops back to myself"

    I have checked the solution on this link

    http://www.howtoforge.com/postfix-mail-for-example.com-loops-back-to-myself

    Rest all Domains Emails are working fine

    Please advice

    God bless you!

    Thanks & regards,

    Abin
     
  7. VIRTUAL

    VIRTUAL New Member

    Hello, this manual “how to duplicate server” is the latest? Because I’ll try move server to new one… (Sorry for my grammar)

     
    Last edited: Oct 13, 2014
  8. Clouseau

    Clouseau Member

    When migrating to new server, what about all thouse DNS zones which have A records pointing to ip address? If those get transfered they are gonna point to old ip address. Is there a way to change the ip address for all DNS zones and records or it has to be done manually?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    you can change them in the ispconfig database with a sql query and then use the ispconfig resync tool to write the new config files.
     
  10. Clouseau

    Clouseau Member

    Tnx. That would be dns_rr table I presume. Do you maybe have some "how to" for complete Debian server migration? :)
     
  11. Johan Bel

    Johan Bel New Member

    Hi,
    The copying of the mysqlfiles to /var/lib/ resulted in a broken setup that i could not get to work.
    So i made a mysqldump of all databases and imported that in 1 go with #mysql -uroot -p < all-database.sql
    This resulted in this error:
    ERROR 1064 (42000) at line 10925: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'STATS_PERSISTENT=0' at line 11​

    But ispconfig seemed to be working.
    Can i safely ignore this error as the websites work as expected ?
     
  12. Johan Bel

    Johan Bel New Member

    After copying the old /usr/local/ispconfig to the new server the setup stopped working
    Without this action all is fine.
    So my question: Why do i need to copy this directory ?
     
  13. ikrudolf

    ikrudolf Member

    Johan Bel likes this.
  14. Johan Bel

    Johan Bel New Member

    Hey Skoena, Thanks for pointing me to that migration howto i will give it a try
    I want to have a offline restore option because I just went through a rather painful disaster crash recovery of my webserver, which resulted in me having to manually copy every database and website into the ispconfig and manually adding the users and sites...
    Sofar copying the /var/www /var/vmail /var/db restoring the mysqldump and hitting resync seems to do the job. I'm just wondering whether I missed something that causes problems later on.
     
  15. mooseman

    mooseman New Member

    Hi,
    I'm running ISPConfig 3 on Ubuntu 12.04 using the Perfect server guide: The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3)

    My old server HD got corrupted during a power faillure, I have a duplicity backup of the server from the previous night with the following exclusions:
    --exclude /media \
    --exclude /mnt \
    --exclude /proc \
    --exclude /sys \
    --exclude /tmp \
    I tried installing a fresh ubuntu 12.04 and restore the duplicity backup (from an SMB share) with a --force command but it freezes the system a few minutes after execution. (no network or disk activity)

    Does anyone have any idea why it would freeze? Am I overwriting a critical Linux file during the restore?

    In the mean time....
    I started to follow the instructions here and built a new server with ISPconfig 3.
    I started dumping the duplicity backup into a folder on the local disk of the new server (it's not freezing when I don't force an overwrite and I specify a restore location) and I'm getting ready to move files into their appropriate place. Based on what I'm reading I have a feeling I will run into problems after copying the mysql files to /var/lib/mysql and I am unable to to do a mysql dump since the old server is dead.

    Any advice or suggestions?
     
  16. Johan Bel

    Johan Bel New Member

    I'd keep the version the same as your old mysql and dump that database before anything else. After that reinstall the ispconfig
     
  17. mooseman

    mooseman New Member

    So migration went pretty smooth...
    I first installed the same ubuntu release with ISPConfig ready and tested.
    As soon as duplicity successfully restored data to a temp folder (which took forever), I migrated (using cp -pr or mv ) the /var/vmail and /var/www files from the old data to their new location.
    I also copied over /var/lib/bind
    Successfully performed Mysql DB migration via copying (retaining previous permisions: cp -pr <source /var/lib/mysql/> /var/lib/mysql/ ) the files in /var/lib/mysql/ which worked without any problems.

    I followed the proceedures described in this thread by "pedm" and "pawan" with some slight midifications..

    I didn't replace the passwd, shadow, gshadow and groups and their respective passwd-, shadow-, gshadow- and groups- files but just added the web users previosuly generated by ISPconfig to the bottom of the new files.

    I replaced (backing up the new versions) the /etc/apache2/ /etc/postfix /etc/bind & /etc/dovecot folders with my old data. I had to cleanup the conf files in /etc/ (or copy more data from the old server) based on extentions and additional applications / services I had installed on the previous server.
    I replaced the /usr/local/ispconfig folder with the one from my old server data
    I also copied over my /var/logs from the previous server which included /var/log/ispconfig and /var/log/apache2
    rebooted... and almost all services came up properly

    I was getting errors like: Access denied for user 'ispconfig'@'localhost' (using password: YES) in the logs after failing to log into services like squirrelmail or when mail was trying to get delivered due to amavis having incorrect credentials.
    This was corrected by finally running the ispconfig_update tool to remap permisions and services or by using the password listed for user ispconfig from /usr/local/ispconfig/server/lib/config.inc.php and corrected other conf files.

    Thanks for all your help and the previous posts.
     
  18. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You can also run the installer on the new server in expert mode and set the password for the ispconfig-server to the one from the old server ;)
     
  19. Dianaclau28

    Dianaclau28 New Member

    hi all.
    I have a problem: i want to move all my clients, and all websites (including all db) to a new ISPConfig. (new server) .
    I am using WINDOWS to move them ( i have a ext4 reader)

    Question: what folders/files do i have to move? I've allready moved var/www/clients /var/lib/mysql /etc/apache2/sites-available and enabled

    I hope i've gave enough information.
    Waiting response....

    Thx in advance!

    Dyana
     
  20. ikrudolf

    ikrudolf Member

Share This Page