ISPConfig 3 Monitor not showing logs or status of slave server.

Discussion in 'Installation/Configuration' started by WeaponX, Nov 15, 2012.

  1. WeaponX

    WeaponX New Member

    I have serveral servers in my multiserver setup. The master ispconfig server is not showing any of the logs of one of my slave servers. The slave server does show up green under monitor, But does not show the ispconfig 3 version under the monitor app or logs of that specific server. All the other ones are showing up fine.

    I have tried looking at the logs and ran the crontab scripts, but no cigar.
    I dont see any errors related to ispconfig. Is there a debug level switch for ispconfig 3? There is no log info under /var/log/ispconfig/ispconfig.log

    Thanks for your help.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Open /usr/local/ispconfig/server/lib/config.inc.php and take a look at the MySQL settings of the ISPConfig user. Are you able to connect with these settings from the slave to the master MySQL server?
     
  3. WeaponX

    WeaponX New Member

    I figured it out last night. In MySQL Database ISPConfig created an extra value of the server in privilages with a different ip then what the server has.

    Example: ispcsrv6 192.168.10.12

    Server needed to be 192.168.10.10 as the root privilages was setup in the biggining. So i just edited that value and changed its ip address.
    Everything is working now.

    Sorry to waste your time.
    Thanks.
     

Share This Page