ISPConfig 3 missing Add new website button

Discussion in 'Installation/Configuration' started by bundlestars, Jul 30, 2020.

  1. bundlestars

    bundlestars New Member

    Hello friends, after following this great and detailed tutorial and successfully installing everything:
    Code:
    https://www.howtoforge.de/anleitung/der-perfekte-server-centos-74-mit-apache-postfix-dovecot-pure-ftpd-bind-und-ispconfig-31/
    And after adding my first client, it quickly became clear that I couldn't add websites as an administrator or a client.
    There is only an Add new record button but it doesn't do anything.

    Now I'm wondering what I could have done wrong so this option is missing on my Centos 7 server instance.
    I searched for a good 4 hours for a reason before I created a new account here and wrote this post.

    I hope I created this thread in a correct forum and since this is my first post, I ask you not to be mad at me if I created it in the wrong section.
    I will give up on this project if I have to reinstall the whole thing according to the tutorial above again.

    It would be great if someone could give me a single database table from an example website so that I can import it into ispconfig database manually.
    I'm asking you to help me solve this problem I currently have with this great script. Thanks in advance.
     

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Click on 'website' in the left menu and then on the green button that appears on the right side of it, the label of it can be 'add new record' depending on the ISPConfig version that you installed. If nothing happens in that case, then this can have two reasons, one is that you are using a browser plugin that blocks parts of the ISPConfig UI like a ad or script blocker. The other option is that something that's needed was not installed, probably a PHP module. To find out what that is, take a look at the apache error.log of the server to see which error gets added there when you click that button.

    Makes no sense for two reasons, first, the buttons and their labels do not depend on the database content and the database content of each installation is different as it contains your server-specific details.
     
    bundlestars likes this.
  3. bundlestars

    bundlestars New Member

    Thank you for your answer Till, and for this great tutorial you wrote and of course for this great tool you created.

    I have tried what you suggested and the first solution is something which I already have tried before because I do have a Kaspersky installed and I disabled it on my website for this reason, but that didn't help.

    So I looked at the apache error log as you suggested and this is what got my attention there, it looks like a PHP module issue?
    Code:
    AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive
    mod_fcgid: stderr: PHP Parse error:  syntax error, unexpected ''Save ce' (T_ENCAPSED_AND_WHITESPACE) in /usr/local/ispconfig/interface/web/sites/lib/lang/en_web_vhost_domain.lng on line 77
     
    Last edited: Jul 31, 2020
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you use? You can find the version number on the help page.
     
  5. bundlestars

    bundlestars New Member

    Since I installed everything yesterday, it has to be the latest version which is included in your tutorial?
    Code:
    wget -O ispconfig.tar.gz https://git.ispconfig.org/ispconfig/ispconfig3/repository/archive.tar.gz?ref=stable-3.1
    However, I have fixed this problem by overwriting the existing file with a fresh copy, which I downloaded from the ISPConfig website.

    I have checked the mentioned file, and for some reason, line 77 looked like this, and there was no other content afterward:
    Code:
    $wb['save_certificate_txt'] = 'Save ceNULNULNULNULNULNULNULNULNULNULNULNULNULNULNULNULNULNULNULNUL

    After adding the website nothing happens and the only error in error_log is the second 1 from above:
    Code:
    AH01276: Cannot serve directory /var/www/html/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive
     
    Last edited: Jul 31, 2020
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    That error is fine.
     
  7. bundlestars

    bundlestars New Member

    Okay, that's good to know. However, there is still a missing text which should appear under the Add new record tab, perhaps that's why I can't add a new website?

    Is it safe to simply overwrite the /usr/local/ispconfig/ directory with the files from this downloaded archive or should I run the upgrade from SSH if that is even possible since I have the latest version?

    Do you know of any other error log that I can take a look at?
    Once again, thank you for your time and support.

    EDIT: For some reason, the MariaDB service crashed while adding the website for the first time and the ISPConfig interface became really slow.
    After restarting the MariaDB service, the interface was just as fast as before and I could add the new website without any problems.
     
    Last edited: Jul 31, 2020
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run an update, use the command:

    ispconfig_update.sh

    choose 'git-stable' as update source.
     
    bundlestars likes this.
  9. bundlestars

    bundlestars New Member

    I will do that later because I have to go to work now and I will then write the results here, thanks.
     
  10. Jesse Norell

    Jesse Norell Well-Known Member

    Definitely update as @till said, you may have simply had a corrupt download file you installed from, but with that and the further issues, you might check for filesystem corruption (ie. fsck), and maybe repair all tables to be on the safe side.
     
    bundlestars likes this.
  11. bundlestars

    bundlestars New Member

    I have run the update and it looks like the issue has been fixed now, thank you guys for the support.

    Please edit the title to mark this issue as solved :)
     
    Th0m likes this.

Share This Page