ISPconfig 3 - Mailserver Warning

Discussion in 'Installation/Configuration' started by danhansen@denmark, Apr 19, 2013.

  1. danhansen@denmark

    danhansen@denmark Member HowtoForge Supporter

    Hi,

    Anybody that can tell me what these 2 warnings from the mail-log mean - Can't receive mail by the way:

    Relay access denied
    warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

    It's the "relay" warning which is the reason I can't receive the mails, I guess..

    In the ISPconfig CP "System > Server Config > Mail" there is an "error" when I leave the site:

    ERROR
    Please specify valid RBL hostnames.


    Added: zen.spamhaus.org - Error message in ISPconfig CP went away. but still not receiving any mail...

    Have been reading several sites, tutotials and manuals - but still I am very much i doubt. Is it in the shell there need to be changes or is it in the ISPconfig3 CP? Heres some of the sites I found regarding this problem:

    1. ISPconfig3 Manual: page 189 "4.7.6.4 Relay Recipients"
    2. ISPconfig3 Manual: page 225 "Server > Server Config > Mail" Relay Host/Relay User
    3. http://beginlinux.com/server_training/mail-server/1041-postfix-mail-server-set-up "4. Configure Relays"
    4. http://www.howtoforge.com/forums/showthread.php?t=53319 Where the mydestination line in your main.cf was the problem
    5. http://docs.oracle.com/cd/E19563-01/819-4428/bgavb/index.html "18.7.4 To Use DNS Lookups Including RBL Checking for SMTP Relay Blocking"

    Could nr "5" be a solution to the second error message - and then maybe both error messages are related?:

    warning: dict_nis_init: NIS domain name not set - NIS lookups disabled


    Checked for blacklisting:
    Code:
     	Blacklist 	Reason	TTL	ResponseTime	Hide
     OK	AHBL 			62	
     OK	ASPEWS 			31	
     OK	BACKSCATTERER 			62	
     OK	BARRACUDA 			62	
     OK	BBFHL1 			47	
     OK	BBFHL2 			47	
     OK	BLOCKLIST.DE 			62	
     OK	BSB 			16	
     OK	BURNT-TECH 			16	
     OK	CASA-CBL 			218	
     OK	CASA-CBLPLUS 			234	
     OK	CBL 			31	
     OK	CHOON 			234	
     OK	DNS-SERVICIOS 			140	
     OK	EFnet RBL 			31	
     OK	IMP-SPAM 			140	
     OK	INPS_DE 			296	
     OK	INTERSERVER 			47	
     OK	ivmSIP 			16	
     OK	ivmSIP24 			16	
     OK	JIPPG 			156	
     OK	LASHBACK 			47	
     OK	MAILSPIKE-BL 			140	
     OK	MAILSPIKE-Z 			140	
     OK	NIXSPAM 			328	
     OK	NOMOREFUNN 			140	
     OK	NoSolicitado 			16	
     OK	PSBL 			94	
     OK	RATS-Dyna 			16	
     OK	RATS-NoPtr 			78	
     OK	RATS-Spam 			78	
     OK	REDHAWK 			62	
     OK	SEM-BACKSCATTER 			47	
     OK	SEM-BLACK 			16	
     OK	SORBS-DUHL 			47	
     OK	SORBS-SPAM 			47	
     OK	SORBS-WEB 			47	
     OK	SPAMCANNIBAL 			47	
     OK	SPAMCOP 			47	
     OK	Spamhaus-ZEN 			62	
     OK	TRUNCATE 			109	
     OK	UCEPROTECTL1 			47	
     OK	UCEPROTECTL2 			47	
     OK	UCEPROTECTL3 			62	
     OK	WPBL 			0
    
    Please point me in the right direction o)


    Kind Regards,
    Dan
    ---------------------------------------------------------------------------------------------------------------------------------
    Internet Service Information:
    Internet Line/Used only for Internet-Servers.
    Static/Fixed public IP
    All ports opened in router --> "ispserverip"
    Primary nameserver --> ns1.myprimarynameserver.tld
    Secondary nameserver --> ns2.somedanishdomainservice.tld

    System Information:
    Ubuntu Server 12.04 (upgraded - do-release-upgrade*)
    ISPconfig 3 v.3.0.5.2 (Single Server Setup)
    Primary nameserver - BIND
    SquirrelMail version 1.4.22 - Courier IMAP/POP3
    Database: MySQL Serverversion: 5.5.29-0ubuntu0.12.04.2

    Tutorial: "The Perfect Server - ISPConfig3 - Ubuntu Server 10.04"
    Downloaded Manual for ISPConfig3 by Falko Timme
    * Note's regarding "Release Upgrade": /etc/networks/interfaces added dns-nameservers
    8.8.8.8 8.8.4.4 according to "The Perfect Server - ISPconfig3 - Ubuntu 12.04"
    ---------------------------------------------------------------------------------------------------------------------------------
     
    Last edited: Apr 20, 2013
  2. SamTzu

    SamTzu Member HowtoForge Supporter

    It's a warning, not an error. You eliminate it by removing
    NIS lookups.

    First, find out what setting is using NIS:

    $ postconf | grep nis:

    This outputs something like

    alias_maps = hash:/etc/aliases nis:mail.aliases
    or
    alias_maps = hash:/etc/mail/aliases nis:mail.aliases

    Then, disable NIS lookups (as root):

    # postconf -e alias_maps=hash:/etc/aliases
    or
    # postconf -e alias_maps=hash:/etc/mail/aliases

    The exact command depends on "postconf | grep nis:" output.


    First thing you should do is to check if SMTP is up and running.
    On mail server you can check this with this command...

    Can you see SMTP? (Usually on port 25.)
    If that is up then you are most likely dealing with a DNS problem (NIS lookups seem to indicate that anyway.)
     
    Last edited: Apr 20, 2013
  3. danhansen@denmark

    danhansen@denmark Member HowtoForge Supporter

    Hi Sam,

    Thanks for your reply.
    I will try that command right now to see what I can learn from that.

    Thanks for the fix above. :)
     

Share This Page