Ispconfig 3 mail filter add unnecessary character

Discussion in 'HOWTO-Related Questions' started by Gábor Vörös, Jan 14, 2015.

  1. Gábor Vörös

    Gábor Vörös New Member

    Hello!

    I like use mailfilter from roundcube. I try it but not work. When I try make rules, from IspConfig admin surface the problem was same.

    When [email protected] send mail for me, delete the mail. I create this rules from Ispconfig
    And this is result:
    ### BEGIN FILTER_ID:16
    if header :regex ["from"] ["[email protected]\.hu$"] {
    discard;
    stop;
    }
    And this rules is not work :(

    When I correct from command promt:
    ### BEGIN FILTER_ID:16
    if header :regex ["from"] ["[email protected]"] {
    discard;
    stop;
    }
    Will work correct. Why this?
    The languange is hungarian.

    p.s.: sorry for my english
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig regex is correct, you just selected the wrong option. The from address of an email is not just "[email protected]" if you look at the headers of an email then you will see that that the from address of an email is something like:

    Your name <[email protected]>

    so "[email protected]" is just a part of the from address and therefor you have to use:

    Contains: [email protected]

    and not

    Is: [email protected]

    for your filter as you did not specify the complate from address as it appears in the email.
     
  3. Gábor Vörös

    Gábor Vörös New Member

    Really!

    Thx. I will spin the lamercounter :D
    Pls delete the post.

     

Share This Page