ISPConfig 3 is not loading (along with all websites)

Discussion in 'General' started by ihsir, Jun 18, 2012.

  1. ihsir

    ihsir New Member

    I had set up a box following the instructions from The Perfect Server - Ubuntu 11.04 tutorial. After receiving help from both Falko and Pititis, everything worked nicely.

    Last week I turned of the computer and kept it off for a few days. I turned it back on and can SSH into it via Putty (both from inside the network and from outside the network), but I cannot access ISPConfig from http://ipaddressOfMachine:8080. Even the default machine page http://ipaddressOfMachine:80 is not loading.

    I restarted the server and the issue is persisting. How to find out what is wrong and how to fix this issue?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Start apache with:

    /etc/init.d/apache2 start
  3. ihsir

    ihsir New Member

    Thank you Till,
    This is the outcome.

    [email protected]:~$ /etc/init.d/apache2 start
     * Starting web server apache2                                                  Syntax error on line 6 of /etc/apache2/conf.d/squirrelmail.conf:
    AddType requires at least two arguments, a mime type followed by one or more file extensions
    Action 'start' failed.
    The Apache error log may have more information.

    In /var/log/apache2, there are a ton of logs:
    [email protected]:/var/log/apache2$ ls
    access.log        error.log.1              other_vhosts_access.log.1
    access.log.1      error.log.10.gz          other_vhosts_access.log.10.gz
    access.log.10.gz  error.log.11.gz          other_vhosts_access.log.11.gz
    access.log.11.gz  error.log.12.gz          other_vhosts_access.log.12.gz
    access.log.12.gz  error.log.13.gz          other_vhosts_access.log.13.gz
    access.log.13.gz  error.log.14.gz          other_vhosts_access.log.14.gz
    access.log.14.gz  error.log.15.gz          other_vhosts_access.log.15.gz
    access.log.15.gz  error.log.16.gz          other_vhosts_access.log.16.gz
    access.log.2.gz   error.log.2.gz           other_vhosts_access.log.2.gz
    access.log.3.gz   error.log.3.gz           other_vhosts_access.log.3.gz
    access.log.4.gz   error.log.4.gz           other_vhosts_access.log.4.gz
    access.log.5.gz   error.log.5.gz           other_vhosts_access.log.5.gz
    access.log.6.gz   error.log.6.gz           other_vhosts_access.log.6.gz
    access.log.7.gz   error.log.7.gz           other_vhosts_access.log.7.gz
    access.log.8.gz   error.log.8.gz           other_vhosts_access.log.8.gz
    access.log.9.gz   error.log.9.gz           other_vhosts_access.log.9.gz
    error.log         other_vhosts_access.log
    Which one should I look into?
  4. MaddinXx

    MaddinXx Member HowtoForge Supporter

    Hi ihsir

    You can see, that the error is in file /etc/apache2/conf.d/squirrelmail.conf on line 6.

     Syntax error on line 6 of /etc/apache2/conf.d/squirrelmail.conf:
    Check the AddType there. If needed, do a google on how it should look like.

    To you other questions, errors are always logged within error.log.
  5. ihsir

    ihsir New Member


    The AddType that was in the file was:
    AddType application/x-httpd-php.php
    It should have been:
    AddType application/x-httpd-php .php
    (with a space before the .php).

    After making this change (with sudo), rebooted the server and I'm now able to access the sites and ISPConfig.

    Thank you all!

Share This Page