ISPConfig 3 + .htaccess

Discussion in 'Installation/Configuration' started by vikmur, Jun 17, 2009.

Thread Status:
Not open for further replies.
  1. vikmur

    vikmur New Member

    Hi,
    Maybe someone would be kind enough to help solve out a problem. With ISPConfig 3 installed I can't use .htaccess files, as if it's in server's root directory, pointing to website brings out this kind of error:
    After deletion of .htaccess file everything works just fine....
     
  2. fhawk

    fhawk New Member

    show your .htaccess!!
     
  3. vikmur

    vikmur New Member

    Even tho it can be empty have rewrite rules or whatever of text in it, result is still the same....

    That's why I didn't post .htaccess file before :p
     
  4. fhawk

    fhawk New Member

    you try:
    <IfModule mod_php5.c>
    php_flag magic_quotes_gpc off
    php_flag register_globals off
    </IfModule>
     
    Last edited: Jun 17, 2009
  5. vikmur

    vikmur New Member

    Same result: Error 500 ...
     
  6. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Please post the corresponding entries in the apache error log.
     
  7. vikmur

    vikmur New Member

    error.log:

     
  8. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    For security reasons you cannot change php settings via .htaccess as a client.
    Imagine you were a hosting provider with 100 clients where each client could break out of his limits by setting php flags ;)
     
  9. vikmur

    vikmur New Member

    Imagine, that this is exact what I need to do... many different sites, with different requirements of php flags...
     
  10. Croydon

    Croydon Member Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes but you should not let the clients set them theirselves.
    Maybe you could use the "Options" tab in a site's settings page as admin.
    There you can define apache directives (like php flags).
     
  11. vikmur

    vikmur New Member

    Edit: Re-checked and not working tho...
     
    Last edited: Jun 18, 2009
  12. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This is definately working and the correct solution. So if it dont work for you, there is still another error. Make sure that you deleted the .htaccess file after you moved the content to the apache directives field.
     
  13. vikmur

    vikmur New Member

    .htaccess is removed, actually it gives no Error this time, but for gpc_magic_quotes off is not working when set at the apache directives...
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the exact error messages that you get in the log files and in the scripts.
     
  15. vikmur

    vikmur New Member

    No error messages prodused, but still:

    Your webserver is configured to enable Magic Quotes. This may cause problems if you use punctuation (such as quotes) when doing data entry. You should contact your webmaster to disable Magic Quotes
     
  16. fhawk

    fhawk New Member

    Make php as Apache module,not CGI or other!!!
     
    Last edited: Jun 18, 2009
  17. vikmur

    vikmur New Member

    Thanks it helped :) Thread is closed...
     
Thread Status:
Not open for further replies.

Share This Page