ISPConfig 3: How to Retore Multiple Sites

Discussion in 'General' started by reason8, Aug 22, 2013.

  1. reason8

    reason8 Member

    How do I restore multiple sites in ISPConfig 3?

    I have a fresh install of an OS (opensuse 11.1 to 11.4) and have copied over all sites under /srv/www.

    I have also imported the sql dump but sites-enabled is not populated with anything (even after copying over my sites-available).

    Is seems I can go into ISPConfig dashboard and DISABLE/ENABLE the sites and that works but I don't want to do this for every website!

    Is there an easier way?

    Also, I imported the mysql dump. Do I need to copy over the files from /var/lib/mysql as well?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    See tools > resync in ispconfig.
  3. reason8

    reason8 Member

    Ok. Thanks. That seems to have worked but I have a question:

    I was using ISPConfig3 on openSUSE 11.1.

    I have recently installed Ubunsu Server 13.04 and moved my websites and data over.

    I ran the ISPConfig resync.

    Ubuntu stores websites under /var/www

    While openSUSE 11.1 stored them in /srv/ww

    Can I simply make the path adjustments in the CPanel? Under System - Server Config - Web?

    Making changes to:

    Website basedir
    Website path
    Website symlinks
  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You can change the path for the websites in ispconfig. But keeep in mind, that there are more differences between opensuse and ubuntu. afaik opensuse uses wwwrun for the apache-daemon while other os run the daemon under www-data. Maybe you must change the owner of some files, too or change the daemon-user and also modify suexec.

    Beside this, there are different UID in the passwd.
  5. reason8

    reason8 Member

    I ran " tools > resync in ispconfig" and I believe it added the entries to /etc/passwd and /etc/group (atleast there were entries there when I checked).

    I am aware of the differences in apache users. I was wondering/hoping if running the rsync applied the new www-data owner to the appropriate files and folders. Can someone confirm this for me please?
  6. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    As long as you have no files not owned by the web-user it should work.

    I switched some servers from opensuse to wheezy and had a lot of files / dirs owned by "wwwrun.www" instead of "www-data.www-data". You can use something like
     find -uid UID -exec chown NEW_UID {} +
    to change these permissions.

    Beside this you can´t use /srv/www as the document_root with suexec but you can intall apache2-suexec-custom or re-compile mod_suexec to change the path (change document root of mod_suexec)
  7. reason8

    reason8 Member


    Does running RESYNC fix/change the apache web ownser permissions?
  8. reason8

    reason8 Member

    Ok. So I am having an issue.

    I moved my data over to the new server. ISPConfig loads.
    I resynced the data but my websites are not comming up.

    I checked under one of my sites and the PHP open_basedir is pointing to the old /srv/www folder on the openSUSE server instead of /var/www on the new Ubuntu Server.

    What is the best way to resolve this?
  9. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Change the settings in the database and re-run the rsync-tool. If you´re using CMS-systems you may change some cms-related configs, too.

    Or just change our system to use /srv/www instead of /var/www
  10. reason8

    reason8 Member

    In which database?

    Which settings? The problem seems to be that all of the websites are using the same server paths as the original webserver.

    I am currently in the process of just installing opensuse 12.2 and using that instead of ubuntu. But i am willing to try your recommendations.
  11. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Check the database dbispconfig for /srv/www and replace it with /var/www.

    Peronally i would not change the database and the (local) settings for all web-sites. I prefer to just change the document_root for suexec.
  12. reason8

    reason8 Member

    Is there an official answer from the developers on this?

    I am moving from ISPConfig 3 on openSUSE to Ubuntu 12LTS but by default web root is /var/www and not /srv/www.

    I restored my files to /srv/www but when I try to delete files under that /srv directory, I receive permssion denied issues. I think it has something to do with Apache locking the files in that folder but I am not sure. It only happens in the /srv folder.

    I would simply use opensuse 12.3 but myphpadmin will not work properly per the Perfect Server documentation. It repeatedly asks me to download the php file.

    I am simply looking for some version of Linux that runs my existing ISPConfig 3 webserver.

    Please help :confused:
  13. reason8

    reason8 Member


    I resolved the PHP issue. The new version of ISPConfig allows you to use SSL for accessing CPanel. When clicking on the Database link from Cpanel, it assumes HTTPS. Omitting this and the port 8080 was the solution.

    However, I am not having issues trying to update the websites in the /srv/www folder.

    I am receiving the same issues as I did with UBUNTU claiming I do not have permissions to update, delete or remove the clients folder (/srv/www/clients).
  14. reason8

    reason8 Member

    Is there a clean way to upgrade from one version of linux to another?

    I am trying to upgrade from opensuse 11.1 to 12.2 and am having issues.

    Right now am I facing an issue with /etc/groups and /etc/passwd UIDs and GUID's being different on the new server so ALL of the web server files are incorrect.

    Whats the best resolution? Can I simply copy my old passwd and group file over from the old opensuse to the new?

Share This Page