Ispconfig 3 Help

Discussion in 'Installation/Configuration' started by r4faga, Aug 25, 2011.

  1. r4faga

    r4faga New Member

    i m new user with ispconfig 3 on opensuse 11.4. And i need help. after to install Ispconfig i have to do something more? i mean i have to configurate dovecot, imap, amavis and the others stuffs??? when i finished, i go to admin on my browser (by the way my ip is not 192.168.0.1 is 169.254.xxx.xxx, i have to change on configuration of my programs and asignate this ip?), and when i try to create a new client, the ispconfig program freeze it, and i have to kill and start it again. the system stats is ok and mark green, I saw on logs and saw this:

    Mail - Log (Server : xxxxxxxxxxxxx)

    Refresh Sequence:
    Data from: 2011-08-24 10:50

    final part:

    Aug 24 10:45:01 condor postfix/smtpd[3932]: connect from localhost[::1]
    Aug 24 10:45:01 condor postfix/smtpd[3932]: lost connection after CONNECT from localhost[::1]
    Aug 24 10:45:01 condor postfix/smtpd[3932]: disconnect from localhost[::1]
    Aug 24 10:46:11 condor clamd[1789]: SelfCheck: Database status OK.
    Aug 24 10:50:02 condor dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
    Aug 24 10:50:02 condor dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured

    Mail-Warn - Log (Server : xxxxxxxxxxxxxxxx)

    Refresh Sequence:
    Data from: 2011-08-24 10:55
    Aug 22 16:36:03 linux postfix/postfix-script[2924]: fatal: the Postfix mail system is not running
    Aug 22 16:36:28 linux postfix/postfix-script[5142]: fatal: the Postfix mail system is not running
    Aug 22 16:36:34 linux postfix/postfix-script[5463]: fatal: the Postfix mail system is not running
    Aug 22 16:36:42 linux postfix/postfix-script[5851]: fatal: the Postfix mail system is not running
    Aug 23 17:33:22 condor dovecot: Killed with signal 15 (by pid=17743 uid=0 code=kill)
    Aug 24 08:14:11 condor dovecot: dovecot: Killed with signal 15 (by pid=6549 uid=0 code=kill)
    Aug 24 10:25:09 condor dovecot: dovecot: Killed with signal 15 (by pid=8372 uid=0 code=kill)

    Mail-Error - Log (Server : xxxxxxxxxx)

    Refresh Sequence:
    Data from: 2011-08-24 10:55
    Aug 22 16:36:03 linux postfix/postfix-script[2924]: fatal: the Postfix mail system is not running
    Aug 22 16:36:28 linux postfix/postfix-script[5142]: fatal: the Postfix mail system is not running
    Aug 22 16:36:34 linux postfix/postfix-script[5463]: fatal: the Postfix mail system is not running
    Aug 22 16:36:42 linux postfix/postfix-script[5851]: fatal: the Postfix mail system is not running


    ystem Messages - Log (Server : xxxxxxxxxxxxxxxxxxxxx)

    Refresh Sequence:
    Data from: 2011-08-24 10:55

    Aug 24 10:50:01 condor /USR/SBIN/CRON[4364]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
    Aug 24 10:50:02 condor pure-ftpd: (?@::1) [INFO] New connection from ::1
    Aug 24 10:50:02 condor pure-ftpd: (?@::1) [INFO] Logout.
    Aug 24 10:51:01 condor /USR/SBIN/CRON[4487]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
    Aug 24 10:52:01 condor /USR/SBIN/CRON[4584]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
    Aug 24 10:53:01 condor /USR/SBIN/CRON[4678]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
    Aug 24 10:54:01 condor /USR/SBIN/CRON[4786]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
    Aug 24 10:55:01 condor /USR/SBIN/CRON[4876]: (getmail) CMD (/usr/local/bin/run-getmail.sh > /dev/null 2>> /var/log/ispconfig/cron.log)
    Aug 24 10:55:01 condor /USR/SBIN/CRON[4875]: (root) CMD (/usr/local/ispconfig/server/server.sh &> /dev/null)
    Aug 24 10:55:02 condor pure-ftpd: (?@::1) [INFO] New connection from ::1
    Aug 24 10:55:02 condor pure-ftpd: (?@::1) [INFO] Logout.


    Freshclam - Log (Server : xxxxxxxxxxxxxxxxx)

    Refresh Sequence:
    Data from: 2011-08-24 11:10
    Unable to read /var/log/freshclam.log


    ClamAV - Log (Server : xxxxxxxxxxxxxxx)

    Refresh Sequence:
    Data from: 2011-08-24 11:10
    Unable to read /var/log/clamd.log

    Fail2Ban Log (Server : xxxxxxxxxxxxxxxx)

    Data from: 2011-08-24 11:10
    Unable to read /var/log/fail2ban.log


    Sorry if some one think that i m a noob user, but is my firts time with ispconfig, and i want to used for my company.

    I installed isp on opensuse 11.4. But i dont know if other source of linux like red hat is better to work with ispconfig or ispconfig work fine with suse.

    Tanks For help.
    Edit/Delete Message
     
  2. CSsab

    CSsab New Member

    Postfix (and possibly a few other services) are not running:

    For postfix:
    /etc/init.d/postfix reload
    /etc/init.d/postfix restart

    Also check that your mysql database is running.

    You can so this in System -> Server Services

    You don't usually have to configure anything else if you have installed ISPConfig 3 following one of the recommended Howtos.

    Hope this helps
     
  3. r4faga

    r4faga New Member

    Tanks men postfix is running but i reload and restart and mark done. Same to mysql is running. By that way, when i was installing isp and configurate programs to run on start server, i get this warning messege eje:
    chkconfing --add postfix.
    insserv: service network is missed in the runlevels 2 to use mysql
    Postfix 0.off 1.off 2.off 3.on 4.off 5.on 6.off .=:
    I have to set level 2 on insserv service??
     
  4. CSsab

    CSsab New Member

    Is the package chkconfig installed by default on opensuse?

    Looks like a bug in the mysql init script have a look here:
    http://lists.opensuse.org/opensuse-bugs/2011-03/msg00030.html

    Try:
    chkconfig -l | grep network

    and changing the runlevel for mysql to something else like this:
    chkconfig --level 20 mysql on

    Or some other number.
     
  5. r4faga

    r4faga New Member

    ok tanks, i assign to 2 3 5 on, and default start on level 20 or other number. Ill see again logs.
     
    Last edited: Aug 25, 2011
  6. r4faga

    r4faga New Member

    Still freezed ispconfig 3, when i try to create a new user, it freezed. I dont have nothing more on my opensuse, and i installed step by step my isp 3 with falko manual. If i dont have to do something more after install isp, i dont know what is going on. It make green on status server like all programs re fine, but on logs still show errors...

    Mail-Error - Log (Server : xxxxxxxxxx)

    Refresh Sequence:
    Data from: 2011-08-24 10:55
    Aug 22 16:36:03 linux postfix/postfix-script[2924]: fatal: the Postfix mail system is not running
    Aug 22 16:36:28 linux postfix/postfix-script[5142]: fatal: the Postfix mail system is not running

    And postfix is running, i dont know what i have to do....
     
    Last edited: Aug 25, 2011
  7. falko

    falko Super Moderator ISPConfig Developer

    Is this a physical server or a virtual machine? If you use OpenVZ, what's the output of
    Code:
    cat /proc/user_beancounters
    ?
     
  8. r4faga

    r4faga New Member

    Is a physical server falko and /user_beancounters is no exist on this folder.
     
  9. falko

    falko Super Moderator ISPConfig Developer

    How much RAM does the system have?
     
  10. r4faga

    r4faga New Member

    have 4 g ram.

    Falko i reinstall all system, and i do it again, step by step with your manual. All steps i do it well. Mark fine with out erros. What do you suggest me, install opensuse or other linux and try to install isp therer?

    My server is a dell poweredge t110 2.

    If i change the name server when i installed, (server1.example.com to company.example.com) this affect to something on my installation??
     
    Last edited: Aug 30, 2011
  11. falko

    falko Super Moderator ISPConfig Developer

    I recommend Debian Squeeze. I suggest you use the real hostname in your installation from the beginning.
     
  12. nikita11

    nikita11 New Member

    same here

    It happened to me too... sometimes when i add something it freeze(opensuse 11.4). I deleted all sites, clients, dns zones, and users i have created before.
    I ran the following command to clear mysql databases:
    mysqlcheck --all-databases --auto-repair -p_sqlpassword_
    then i started by adding 1 client(directly under admin, no resellers) following by 1 site for that client, following 1 domain for the mail(property of the client), and then started adding mailboxes.
    It didn't freeze anymore, but anyways, when it freezes(being only the control panel) i restart apache2 and it comes back. fortunately i only have 1 domain to host, nothing complicated. I hope it works for you too.
     

Share This Page