ISPConfig 3 - getmail

Discussion in 'General' started by airton, Jan 28, 2009.

  1. airton

    airton New Member

    I'm trying ispconfig3 from SVN: is a very good work!! Thanks to developer.
    My question is about getmail.
    I've found no entry in getmail user crontab and so the script getmail.sh is never invoked. Seem installer (installer_base.lib.php lines 1059-1081) doesn't create these entries.
    Thanks.

    PS: IMHO could be usefull to create a forum section dedicated to ISPConfig 3.0!
     
  2. till

    till Super Moderator

    I've added this to the bugtracker.
     
  3. DonAteloNow

    DonAteloNow New Member

    Error: configuration file /etc/getmail/*.conf does not exist

    Hello,

    I'm getting this error in ISPC-Cron-log.
    Error: configuration file /etc/getmail/*.conf does not exist


    Information in /usr/local/ispconfig/server/scripts/getmail.sh
    #!/bin/bash
    getmail -g /etc/getmail/ -r /etc/getmail/*.conf

    But I have no files in /etc/getmail/

    What is the best way to solve this problem?

    Thanks, guys.
     
  4. till

    till Super Moderator

    Thats fine as you have not created any getmail accounts yet, its not a problem.
     
  5. airton

    airton New Member

    Another bug? (solved)

    getmail version 4.7.8 (Debian lenny)

    If there is more than one retrive task (more .conf files in /etc/getmail) the mail isn't retrieved an is logged an error:

    Error: unknown argument(s) ['/etc/getmail/mail.domain.tld_name@site.tld.conf'] ; try --help

    For handling multiple task seem getmail require to be invoked with a different syntax:

    /usr/bin/getmail -n -v -g /etc/getmail -r /etc/getmail/file1.conf -r /etc/getmail/file2.conf -r /etc/getmail/file3.conf

    or with a single rcfile with configuration for multiple tasks.

    I've solved in this way:

    1 - in /etc/getmail create a file /run-getmail.sh (chown getmail + chmod 744)

    Code:
    #!/bin/sh 
    set -e 
    cd /etc/getmail 
    rcfiles="" 
    for file in *.conf ; do 
      rcfiles="$rcfiles -r $file" 
    done 
    #echo  $rcfiles
    exec /usr/bin/getmail -n -v -g /etc/getmail $rcfiles
    2 - edited crontab of user getmail to invoke this script
    Code:
    */5 * * * * /etc/getmail/run-getmail.sh  > /dev/null 2>> /var/log/ispconfig/cron.log
     
    Last edited: Mar 12, 2009
  6. till

    till Super Moderator

    Thanks, I added it to the bugtracker.
     

Share This Page