ispconfig 3 expert setup

Discussion in 'Installation/Configuration' started by enigma, Sep 8, 2008.

  1. enigma

    enigma New Member

    I got version 3 working perfectly on the local server but i like the idea of it being able to use other servers for different services but there's something wrong with the Expert setup script.

    When it asks you to input the location of mysql i change localhost to the location of where my mysql server is located. Then i input the username/password/database name. After the database name it does nothing execpt go back to the command line without an error.

    Would it be eaiser if i copied the local database to the remote server and then specified the location?

    Should the script create the database automatically even if it's not local?
     
  2. till

    till Super Moderator

    Which version did you install?

    No, this wont work as you would have to change many config files manually then.

    That depends on the options you choosed. If you choose to create the datbabase, then yes. If you chosse to create no database, then it wont create the db of course.
     
  3. enigma

    enigma New Member

    Is there a way from the terminal to remotely connect to a mysql database and test it as telnet says connection refused.

    If my problem is related to something blocking the connection i have no clue what it could be. I've allowed the port 3306 in iptables and i can connect to mysql through phpmyadmin (although that is port 80). Would App armor be blocking it or some hidden service i'm not aware of?
     
  4. till

    till Super Moderator

    Use:

    mysql -h remote.host.com -u root -p

    The command asks you for the password then. Make sure that you use root as username and that no database with the name that you choose for ispconfig exists on the server.

    AppArmor should be disabled, otherweise several functions like logging in pacahe wont work.
     
  5. enigma

    enigma New Member

    I got the remote connection working with mysql. The mysql server wasn't setup correctly as i didn't allow host permissions from the other server. Now that i can remotely connect to mysql the ispconfig script still breaks.

    Here's a screenshoot, i've taken out the username/password.
    isconfig 3 is located on 87.117.197.86
    Mysql server is 87.117.197.22

    Any suggestions?
     

    Attached Files:

  6. till

    till Super Moderator

    Which version did you install?
     
  7. enigma

    enigma New Member

    The latest beta - 3.0.0.6
     
  8. till

    till Super Moderator

    Please try to install the latest SVN release. The commands to install the svn version are included in the installation guide. If this fails too, I will make a bug report and have a look at the code what may cause it to fail.
     
  9. enigma

    enigma New Member

    Tried the SVN and same issue.

    If you would like root access or webmin access to the servers it can be arranged.
     
  10. till

    till Super Moderator

    I added this to the bugtracker for review.
     
  11. enigma

    enigma New Member

    I got it to work. It wasn't a bug it was my fault. I removed mysql from the machine and in by doing so also removed the mysql/php link file which is needed to connect to an external database.
     
  12. till

    till Super Moderator

    Thanks for the post. I will cancel the bugtracker entry then.
     

Share This Page