ISPconfig 3, Drupal 7 slow?

Discussion in 'Installation/Configuration' started by iceget, May 5, 2014.

  1. iceget

    iceget Member

    hello community,

    i have the following Problem:
    i have 2 Servers with the following hardwaredetails:
    Root Server Dual - 2 x Intel Xeon E5-2630L - 32 GB ECC RAM - 4 x 1TB 2,5" 10kRPM HDs RAID 10

    on this both Servers vmware esxi 5.5 is running. each virtual ispconfig machine has 16GB RAM and 8 vCpus.
    on both vms i have installed ispconfig 3 with Debian 7.5 Setup + Apache2.

    my Problem: drupal 7 is so slow.

    first vm: ispconfig 3 for WEB
    seond vm: ispconfig 3 for DB

    both Servers on the same vmware host, i also have moved the db Server to the second Hardware.

    if i open the Website with drupal 7, i must wait ~ 3,4 seconds until the next page are open...

    if i move both Servers to the same vmware esxi host, it is the same Speed..

    what i can do? the Servers itself has 500mbit up and down...

    can anyone help me? maybe a Problem with the splitted WEB / DB Server?
    i Need them for high loads... what i can do?


    many greets
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to optimize the mysql settings on your database server. When the database server uses mysql 5.5 or later, then you have to change the mysql defaults for better performance. Innodb is very slow in the latest versions if you do not optimize the settings to use more ram for caching.

    The problem is not related to ispconfig as ispconfig has no influence on mysql or php performance.
  3. frprim

    frprim New Member

    check if xcache is enabled by typing in console : php -v

    Also check your server load. I use htop ie. apt-get install htop . You can see if there is a process that is hoging your sistem.
  4. diablo666

    diablo666 Active Member HowtoForge Supporter

    In my company i'll use Drupal con my ispconfig servers without any issue.

    May be the problem is in the connection from the web server and the db server?

    You tried some speed test between the 2 nodes?
  5. 8omas

    8omas Member HowtoForge Supporter

    I had the same problem.
    I got the best results after tweaking mysql parameters, disabling some Drupal 7 modules and enabling a php accelerator (eg APC)

    For example increase (a lot) the

    • innodb_buffer_pool_size
    • query_cache_size
    • max_heap_table_size
    • key_buffer_size

    Search for mysql optimization and drupal 7 performance tips.
    Also you can use mysqltuner and/or tuning-primer

Share This Page