ISPConfig 3 DNS Zone Records

Discussion in 'General' started by onastvar, May 11, 2010.

  1. onastvar

    onastvar Member

    Could somebody please post a screen shot of their ISPConfig 3 DNS Zone Records for:

    domain1.com
    domain2.com
    domain3.com

    I can't figure out what should be the correct DNS Zone Records for:

    domain2.com
    domain3.com

    My domain1.com is working fine.

    Thank You!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Just use the dns wizard to create the zones for domain 2 and 3. It will create all nescessary records in a correct way for you.
     
  3. onastvar

    onastvar Member

    Thanks Till that worked, however, right now I am getting

    Code:
    Apache 2 Test Page powered by CentOS
    I tried to change my IP Address in Sites to "*" as well as my public IP address but I still get Apache 2 Test Page. This server has assigned pubic IP address so I'm not using any private IPs.

    Any ideas what to check?

    Thanks
     
    Last edited: May 12, 2010
  4. Toucan

    Toucan New Member

    Where are the DNS records for the sites you are hosting stored?

    If you are hosting your own DNS records, then you need to have set up a name server record on you server and then given that ns record to the domain registrar.

    This guide explains how to do it:
    http://www.howtoforge.com/ispconfig_dns_providerdomain_schlund

    I put a brief guide to DNS in laymans terms here:
    http://badbison.com/ispconfig3/dns-basics.html
    beware, it is only my understanding of DNS and not approved but it does give an idea how things work in simple terms.

    Hope it helps, but sorry if I'm preaching to the converted!;)
     
  5. onastvar

    onastvar Member

    Thanks!

    I have glue records at name.com. My domain names are pointing to my ISPConfig 3 name servers (ns1.mydomain.com & ns2.mydomain.com) I think they're working as they should (since I'm getting Apache 2 Test page). I think there's a problem with VirtualHost, possible something within ISPConfig 3 setup.

    Any other ideas, what should I check?
     
  6. Toucan

    Toucan New Member

    When I did it, propogation made me wait the full 72 hours! Then it all worked.
     

Share This Page