ISPconfig 3 DNS problems

Discussion in 'Installation/Configuration' started by Lanta, Dec 15, 2012.

  1. Lanta

    Lanta New Member

    Hi at all.

    Maybe I'm only one of the many noobs that is coming here in HoWToForge asking for the DNS problem. But I manager for 2 years a DirectAdmin server and never had problems, so I think maybe I'm missing something.

    I'm using Debian 6 default OVH distribution for ISPconfig 3 on a Kimsufi.

    Correct me if I'm wrong. There are 2 ways to setup DNS:
    PS: I'm trying to set a first domain called www.ver1tas.it. The problem is that ISPconfig is not loading my site uploaded by FTP!
     
    Last edited: Dec 16, 2012
  2. Ghostdare

    Ghostdare Member

    Every site must have a name server at registrar. So , if your IP is XX.XY.XC.XXD create a A record as ns with that IP in your DNS Zone, and also at TLD (in my case RO TLD) make sure that yourdomain.net point to ns.yourdomain.net - doesn't matter if are the same IP's.

    If you create with wizard the zone must look look that
    Example
    A yourdomain.ro. 86.xxx.xxx.147 0
    A mail 86.xxx.xxx.147 0
    A ns 86.xxx.xxx.147 0
    A www 86.xxx.xxx.147 0
    MX yourdomain.ro. mail.yourdomain.ro. 10
    NS yourdomain.ro. ns.yourdomain.ro. 0
     
    Last edited: Dec 16, 2012
  3. Lanta

    Lanta New Member

    I found no problem with setting up DNS, with the method 1 (using domain provided DNS server) and method 2 (using internal server DNS). The problem is that ISPconfig is actually loading the main site page instead of the website uploaded by FTP.
    Can't figure out WHY. Maybe vhosts problems?
     
  4. Lanta

    Lanta New Member

    It didn't create my VirtualHosts... just one of 3 domains.

    PS: opened etc/apache2/httpd.conf and it's empty OMG
     
    Last edited: Dec 16, 2012
  5. Ghostdare

    Ghostdare Member

    That is your problem.....vhosts.

    Actually httpd.conf is empty, i've checked my file. Do you have sites created in sites-available and sites-enabled?
     
    Last edited: Dec 16, 2012
  6. Lanta

    Lanta New Member

    httpd.conf it's empty
    That's insane, because it is the default Debian6 distro for ISPconfig by OVH.

    How to re-create it?
     
    Last edited: Dec 16, 2012
  7. Lanta

    Lanta New Member

    Yes, they are all here.
     
  8. Ghostdare

    Ghostdare Member

    You are behind a firewall? If so, if you have a rule that point to an IP is no good.

    My rule is like in the attachment.

    PROTO -> tcp
    SOURCE -> *
    PORT -> *
    DESTINATION -> *
    PORT -> 80
    GATEWAY -> *
     

    Attached Files:

  9. Lanta

    Lanta New Member

    The only firewall I have at the moment is the firewall integrated into ISPconfig, and I have a rule that opens the ports needed.

    I just tried to re-create the domain, it seems to work... still can't understand how. I'll let you know in some days.
     
    Last edited: Dec 16, 2012
  10. Ghostdare

    Ghostdare Member

    I've tried to check your record www.ver1tas.it at http://mxtoolbox.com and make a dns lookup and reported nothing.

    Are you sure that you've set corect ns/zone for you site?

    -------------------
    smtp:ver1tas.it

    smtp
    No A records exist for ver1tas.it.

    DNS Transcript - 1 m.dns.it 217.29.76.4 NON-AUTH Recieved 4 Referrals , rcode= NS: dns4.arubadns.cz,NS: dns2.technorail.com,NS: dns.technorail.com,NS: dns3.arubadns.net,

    2 dns4.arubadns.cz 81.2.199.73 AUTH Recieved 1 Referrals , rcode= SOA: mname=ns.kimsufi.com/rname=hostmaster.ver1tas.it/serial=1,

    dns lookup ns lookup mx lookup whois lookup
    Reported by mxtoolbox.com on Sunday, December 16, 2012 at 6:03:33 AM (History)
     
    Last edited: Dec 16, 2012
  11. Lanta

    Lanta New Member

    The problem is that my domain register (aruba.it) will take 24/48h just to change the nameserver from their ones to my ones. Seems like it's not automatic, but manually done by a person: that's the point.

    Try to set your PC DNS to
    5.39.95.9
    213.186.33.199
    and open www.ver1tas.it. It works.

    I just need to wait Aruba.it DNS change.
     
    Last edited: Dec 16, 2012
  12. ressel

    ressel Member HowtoForge Supporter

    When you open your website in ispconfig is the ip address set to * or a ip address?
    If it's set to * try change it to your ip address.
     
  13. Lanta

    Lanta New Member

    Already tried. That's not the problem. ;)
     
  14. Lanta

    Lanta New Member

    Still get the Virtual hosts problems.

    Can someone say me how to add the NameVirtualHost directive needed... and WHERE. Thanks.
     
  15. Lanta

    Lanta New Member

    Maybe that's the problem. I never looked into the server configuration of ISPconfig before.

    [​IMG]

    IP and gateway are good like this?
    I never seen this DNS, except of 127.0.0.1 that obviously point to the internal bind server.
    WTF is network configuration tickbox?
     

Share This Page