ispconfig 3 debian lenny apache2apache2: Could not reliably determine the server

Discussion in 'Installation/Configuration' started by sygram, Jul 19, 2010.

  1. sygram

    sygram New Member

    Greetings to all,

    i have just completed the installation of ispconfig 3 on a fresh debian lenny 64. I would like your help in the following issues please :

    1) ispconfig 3 does not install a separate apache anymore ?
    2) why do i get the below when restarting apache2 ?

    Restarting web server: apache2apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    [Mon Jul 19 22:13:58 2010] [warn] NameVirtualHost 111.22.33.44:443 has no VirtualHosts
    ... waiting apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    [Mon Jul 19 22:13:59 2010] [warn] NameVirtualHost 111.22.33.44:443 has no VirtualHosts
    .
    3) /etc/mail/local-host-names does not contain the domains. Will i get infinite loop when sending an email ? I think i had to add the domain in ispconfig 2.
    4) Is there a website backup tool as in version 2 ? I can not seem to find it.

    Thank you very much for your replies.

    Regards
     
  2. matty

    matty New Member

    Regarding #2, you need some DNS entries for your server. I'm a bit rusty with apache, but you might be able to fool it in the meantime with the right /etc/hosts entry and another service restart.

    111.22.33.44 webbox.example.com webbox

    Edit: it's also possible that you aren't pointing your server at a working nameserver in /etc/resolv.conf.
     
    Last edited: Jul 20, 2010
  3. sygram

    sygram New Member

    Hi Matty,

    thanks for your reply.

    /etc/hosts does contain the mentioned entry and /etc/resolv.conf contains 4 name servers.

    I think in this issue i have 2 problems :

    a) [warn] NameVirtualHost 111.22.33.44:443 has no VirtualHosts
    b) Could not reliably determine the server's fully qualified domain name

    i think i solved 1). Port 443 was defined in ports but i had no virtual host defined using this port (as it was saying) . I added ssl certificate from ispconfig and i do not get this error anymore (added 443 entry in sites-enabled). At this point i would like to mention that the control panel had very weird behavior when doing this. First time clicked create certificate it took me to another page and then it would not respond to any requests. I clicked somewhere and i got an alert window with an xml response.

    regarding b) i added ServerName "hostname" to apache2.conf and i do not get this message anymore. I think it is because hostname does not contain domain. The weird thing is that hosts has
    ip full domain hostname entry

    Any thoughts on issues 1, 3,4 ?

    Regards
     
    Last edited: Jul 20, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

    That's right.

    The domains and email accounts are now stored in MySQL. It's a totally different setup.
    There is one in the SVN - it will be part of the next stable release.
     
  5. sygram

    sygram New Member

    Thanks for the reply Falko.

    so i guess we have to protect mysql really well. If it fails for any reason nothing will work right ? Any fail safe process ?

    Although we had experience with ispconfig 2 we decided to move to 3 thinking that support from 2 will soon end ... Is this true or 2 will continue to be supported ? What i mean is version 3 is suggested right ?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    And if postfix or courier or the kernel, or syslog or the harddisk will stop, mail will not work as well. This setup is as reliable as the file based setup.

    ISPConfig 2 is a different software then ISPConfig 3. Both software packages are stable and actively maintained.
     
  7. sygram

    sygram New Member

    thanks for your replies. Much appreciated. We will stay with 3 for now.
     

Share This Page