ISPConfig 3 configuration

Discussion in 'Installation/Configuration' started by scottrill2, Feb 2, 2011.

  1. scottrill2

    scottrill2 New Member

    I am installing ISPConfig 3 and everything was working fine, I hadnt transferred any sites from ISPConfig 2 yet, but could log into control panel and play around etc.


    I was wanting to enable SSL and SuExec for conmtrol panel per the manual on pages 296-298. Enabled SSL just fine logged into control panel, SSL is working etc.


    **A note about SSL in the manual it says to find the tags that are labeled "<VirtualHost &hellip;.></VirtualHost>" Im assuming the part that reads "&hellip;." is a typo, in my file I only have one set of tags and thats "<VirtualHost _default_:8080></VirtualHost>". Or was I supposed to make a new set of tags. SSL did work afterwards, so Im assuming that was correct.


    But when I tried enabling SuExec I ran into problems.

    I did the following:

    vi /etc/apache2/sites-available/ispconfig.vhost
    **Commented out the entire "<IfModule mod_php5.c>" section

    rm -f /var/www/ispconfig

    /etc/init.d/apache2 restart

    After the restart it says:

    server3:~# /etc/init.d/apache2 restart
    Restarting web server: apache2Warning: DocumentRoot [/var/www/ispconfig/] does not exist... waiting Warning: DocumentRoot [/var/www/ispconfig/] does not exist.
    server3:~#

    Then when I try and log into the control panel I get a 403 Forbidden error.

    What did I screw the pooch on folks?


    Thanks as always for your time,

    Scott
     
  2. till

    till Super Moderator

    Please post the file:

    /etc/apache2/sites-available/ispconfig.vhost

    and which ISPConfig 3 version do you use?
     
  3. scottrill2

    scottrill2 New Member

    File info requested

    Contents of /etc/apache2/sites-available/ispconfig.vhost :


    ######################################################
    # This virtual host contains the configuration
    # for the ISPConfig controlpanel
    ######################################################

    Listen 8080
    NameVirtualHost *:8080

    <VirtualHost _default_:8080>
    ServerAdmin webmaster@localhost

    <IfModule mod_fcgid.c>
    DocumentRoot /var/www/ispconfig/
    SuexecUserGroup ispconfig ispconfig
    <Directory /var/www/ispconfig/>
    Options Indexes FollowSymLinks MultiViews +ExecCGI
    AllowOverride AuthConfig Indexes Limit Options FileInfo
    AddHandler fcgid-script .php
    FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
    Order allow,deny
    Allow from all
    </Directory>
    </IfModule>

    # <IfModule mod_php5.c>
    # DocumentRoot /usr/local/ispconfig/interface/web/
    # AddType application/x-httpd-php .php
    # <Directory /usr/local/ispconfig/interface/web>
    # Options FollowSymLinks
    # AllowOverride None
    # Order allow,deny
    # Allow from all
    # php_value magic_quotes_gpc 0
    # </Directory>
    # </IfModule>

    # ErrorLog /var/log/apache2/error.log
    # CustomLog /var/log/apache2/access.log combined
    ServerSignature Off

    <IfModule mod_security2.c>
    SecRuleEngine Off
    </IfModule>

    # SSL Configuration
    #SSLEngine On
    #SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
    #SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key

    SSLEngine On
    SSLCertificateFile /etc/apache2/ssl/ispserver.crt
    SSLCertificateKeyFile /etc/apache2/ssl/ispserver.key

    </VirtualHost>

    <Directory /var/www/php-cgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/php-fcgi-scripts>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    *******************************************************

    ISPConfig 3 Version is 3.0.3.2


    Thanks as always for the help folks,


    Scott
     
    Last edited: Feb 3, 2011
  4. till

    till Super Moderator

    Please run:

    ln -s /usr/local/ispconfig/interface/web /var/www/ispconfig

    to create the symlink and try to access ispconfig again.
     
  5. scottrill2

    scottrill2 New Member

    Awesomeness

    Sweet!!

    Thanks Till,

    It is back up for me now. So did I do that step wrong somehow, or was that step in the manual meant for different distro or something?

    How can I make sure the control panel is running in SuExec, that I did everything correctly?


    Thanks as always folks,


    Scott
     
  6. till

    till Super Moderator

    You did nothing wrong, the symlink is required for suexec. I will correct that in the manual.

    As you commented out the mod_php section and are still able to reach the interface means that it runs now under suexec.
     

Share This Page