ISPCONFIG 3 & Centos 6.4 - ALMOST right but...

Discussion in 'ISPConfig 3 Priority Support' started by craig baker, Jun 24, 2013.

  1. craig baker

    craig baker Member HowtoForge Supporter

    I screwed up - I had installed centos 6.4 with a big home directory (and a small var one) and I forgot to wipe and resize it so I have everything WORKING now - but my /var is almost full

    how can I have ISPCONFIG 3 to use /home instead of /var? safely without having to redo hours and hours and hours of work???
    or maybe symlink it so that everything works without messing up the work?

    *** BETTER PLAN - is there a safe and easy to resize the /home partition smaller (its 1.8TB) and the / partition bigger?
    these are setup as being managed by lvm and are ext 4 from the centos 6.4 install I just did.
    currently:
    [root@ns9 /]# df -v
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/mapper/vg_ns9-lv_root
    51606140 44038720 4945980 90% /
    tmpfs 16471600 236 16471364 1% /dev/shm
    /dev/sda1 495844 62110 408134 14% /boot
    /dev/sr0 1418348 1418348 0 100% /media/CentOS_6.4_Final
    /dev/mapper/vg_ns9-lv_home
    1852386680 191026800 1567264112 11% /home

    help would be appreciated - can I shrink vg_ns9-lv_home and increase the root partition?

    I DONT want to lose everything and symlinks are a kludge at best - I know I should have made home small and / large, but can I salvage the situation?




    thanks :)

    ps love howtoforge I have been a subscriber before


    UPDATED - problem solved.

    use resize2fs and lvexpand as per the following:

    # Unmount the filesystem and check its' LV
    umount /home
    e2fsck -f /dev/mapper/vg_ns9-lv_home

    # Shrink ext4 and then the LV to the desired size
    resize2fs -p /dev/mapper/vg_ns9-lv_home 500G (reduce to 500gb)
    lvreduce -L 500G /dev/mapper/vg_ns9-lv_home

    # Before continuing, run e2fsck. If it bails because the partition
    # is too small, don't panic! The LV can still be extended with
    # lvextend until e2fsck succeeds, e.g.:
    # lvextend -L +1G /dev/mapper/vg0-foo
    e2fsck -f /dev/mapper/vg_ns9-lv_home <- checked ok

    # Resize the filesystem to match the LVs size, check and mount it
    resize2fs -p /dev/mapper/vg_ns9-lv_home
    e2fsck -f /dev/mappervg_ns9-lv_home
    mount /home

    That was the tricky part. The rest is pretty straight forward:

    unmount the filesystem,
    extend the logical volume and
    expand the filesystem afterwards.

    umount /
    <--- dont need to unmount root 6.4 can do it on the fly

    # Extend the LV to use all free space
    lvextend -l +100%FREE /dev/mapper/vg_ns9-lv_root
    e2fsck -f /dev/mapper/vg0-bar <- cant do mounted

    # Resize the partition to fill the LV
    resize2fs -p /dev/mapper/vg_ns9-lv_root
    e2fsck -f /dev/mapper/vg0-bar <- cant do mounted

    sync;reboot! all is joyous and /var now has TONS of room (1.3TB)
     
    Last edited: Jun 25, 2013
  2. craig baker

    craig baker Member HowtoForge Supporter

    moving right along - phpmyadmin??

    I'm wondering how phpmyadmin access works - when I access one of the known sites (DNS and site entry properly) with
    http://www.mysite.com/phpmyadmin

    up pops an .htaccess type box as below demanding to know account and password. No account / password combo that I've tried works!

    A username and password are being requested by http://www.mysite.com. The site says: "phpMyAdmin localhost"

    After giving up it says access denied phpmyadmin 2.11.11.3

    any ideas?
     
  3. craig baker

    craig baker Member HowtoForge Supporter

    yet further advancement. anyone use net2ftp?

    I found an install instruction set for ispconfig 3 but I dont understand one step says to edit a file that does not exist on my server..

    ...steps omitted....
    23. cd /var/www/ispconfig/themes/default/css/screen
    24. nano content_ispc.css or vi content_ispc.css



    content_ispc.css I cant find anywhere. any light to shed?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Which phpmyadmin install instructions do you refer to?
     
  5. craig baker

    craig baker Member HowtoForge Supporter

    phpmyadmin instructions

    perfect server centos 6.4 ispconfig 3 apache 2.

    and one more thing I installed pureftpd as per above installation and I find this in /var/log/messages:

    ----snip-----
    un 26 06:36:22 ns9 pure-ftpd: (justrightrealestateva@192.168.2.1) [NOTICE] /var/www/clients/client0/web11//web/index_htm_files/177.png uploaded (978 bytes, 363.58KB/sec)
    Jun 26 06:36:43 ns9 pure-ftpd: (justrightrealestateva@192.168.2.1) [INFO] Logout.
    Jun 26 06:36:43 ns9 pure-ftpd: (?@192.168.2.1) [INFO] New connection from 192.168.2.1
    Jun 26 06:36:43 ns9 pure-ftpd: (?@192.168.2.1) [INFO] justrightrealestateva is now logged in
    Jun 26 06:36:43 ns9 pure-ftpd: (justrightrealestateva@192.168.2.1) [NOTICE] /var/www/clients/client0/web11//web/index_htm_files/183.png uploaded (691 bytes, 302.19KB/sec)
    Jun 26 06:37:04 ns9 pure-ftpd: (justrightrealestateva@192.168.2.1) [INFO] Logout.
    Jun 26 06:37:04 ns9 pure-ftpd: (?@192.168.2.1) [INFO] New connection from 192.168.2.1
    Jun 26 06:37:04 ns9 pure-ftpd: (?@192.168.2.1) [INFO] justrightrealestateva is now logged in
    Jun 26 06:37:04 ns9 pure-ftpd: (justrightrealestateva@192.168.2.1) [NOTICE] /var/www/clients/client0/web11//web/index_htm_files/184.png uploaded (661 bytes, 104.30KB/sec)
    Jun 26 06:37:25 ns9 pure-ftpd: (justrightrealestateva@192.168.2.1) [INFO] Logout.
    Jun 26 06:37:25 ns9 pure-ftpd: (?@192.168.2.1) [INFO] New connection from 192.168.2.1
    Jun 26 06:37:25 ns9 pure-ftpd: (?@192.168.2.1) [INFO] justrightrealestateva is now logged in
    -------------snip-------------


    pure-ftpd is recording a login and log out for EVERY file transferred. is this by design?? I was wondering why ftp upload was taking so long!
    is there a setting somewhere that logs out after every upload?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    These is the perfect setup for centos and I cant find the instructions you posted above to edit that file:

    http://www.howtoforge.com/perfect-server-centos-6.4-x86_64-apache2-dovecot-ispconfig-3

    I doubt that pure-ftpd logs you out, according to the log, the ftp client quits the connection.Pleasetry to use a different FTP client to see if you get the same behaviour.
     
  7. craig baker

    craig baker Member HowtoForge Supporter

    ftp client issue

    its the same client (built into a web development package) I've used for years. on other servers it uploads rapidly zip zip zip. here took a LONG time and that was in the log...
    maybe a different ftp server rather than pure-ftp?
    thanks.

    One more thing (dont want to dig around in ispconfig source if there is a simple setting somewhere - the default is to list 15 websites etc per page under the sites list. can I change it to default to ALL?

    thanks again!

    ps LOVE ISPCONFIG3. gotten used to it in a short time.
    now if I can only get net2ftp to work..

    did you see the above question? net2ftp/ispconfig3 install instructions mention a file in the default screen css folder that does not exist.
    any ideas?
     
  8. craig baker

    craig baker Member HowtoForge Supporter

    ispconfig 3 installation instructions

    the instructions were to integrate net2ftp with ispconfig 3, not the ispconfig 3 installation itself.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    The logout is initiated by the mail client and not the ftp server. You should check the settings of your mail client.

    No, not without changing the sources of all lists.

    Ok, so not the perfects etup guide. I have not tested net2ftp with ispconfig, so I cant tell you if it will work with current ispconfig releases.
     
  10. craig baker

    craig baker Member HowtoForge Supporter

    net2ftp integration

    the documentation I've found claims success integrating with ispconfig3 - but they refer to a file I cannot find mentioned above.

    var/www/ispconfig/themes/default/css/screen
    24. nano content_ispc.css or vi content_ispc.css

    any idea what the content_ispc.css file is? and why its not in my installation?
    should it be? is it from an older version of ispconfig (though the docs claim success with ispconfig3!)
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    A cascaded stylesheet file of an old ispconfig version. This file does no exist anymore in current ISPConfig 3 releases.
     
  12. craig baker

    craig baker Member HowtoForge Supporter

    alternate ftp server

    if I want to try something other than pure ftpd whats your second choice? working with ispconfig3 of course!
     
  13. craig baker

    craig baker Member HowtoForge Supporter

    more on net2ftp - and that file

    it seems the content_ispc.css exists under the default-304 tree, not the default tree under themes.
    why are there the 2 trees? and can I simply rename them to make default-304 the default one and see if that works?
    thanks
     
  14. craig baker

    craig baker Member HowtoForge Supporter

    sorry missed your reply abot

    I guessed it was default-304 contains the file and the version says its version 3.04 of ispconfig3.

    if I wanted to put this (that used to go into the content_ispc.css file)

    .icons16.icoWebFTP { background-image: url("../../icons/x16/folder_open.png"); }

    in a css file in the current setup where would it be appropriate?
    thanks
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Thereare no other supported FTP daemons and this setup. You cann easily verify your problem, use a different FTP client like fireftp plugin in firefox, if you see the exact same login / logout behaviour, then its a issue on your ftp server setup. If you dont see the same behaviour, then its a issue of your other ftp client.

    themes/default/css/styles.css

    But the menu is handled differntly now, its one sprite grafic that contains all icons and the icon that is shown is selected by its position in the sprite.
     
  16. craig baker

    craig baker Member HowtoForge Supporter

    ok I'll try experimenting

    I'll try and play with it to see if I can incorporate without breaking ISPCONFIG.

    meanwhile is there any other web-ftp type package that IS supported?

    thanks :)
    and again LOVE ISPCONFIG. now if only there were some batch commands :)
     
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Generally you can use any webftp client that supports FTP with ispconfig, but there is no client that is integrated into the ispconfig interface.
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no batch commands but ispconfig has a remote api that can be used in php (shell or web) scripts to automate the creation of sites, ftp users etc. You find the documentation and example scripts in the remote_client folder of the ispconfig tar.gz file.
     
  19. craig baker

    craig baker Member HowtoForge Supporter

    ISPCONFIG - net2ftp information

    I've largely got net2ftp working and integrated have to clean it up a abit I'll post some updated information in the appropriate thread...

    and I'll look at the scripts - JUST as I got done moving over 77 sites and creating everything manually NOW I see there are scripts. me bad.
    ISPCONFIG is great...
     
  20. craig baker

    craig baker Member HowtoForge Supporter

    DNS allow transfers??

    I'm changing the BIND setup and need all dns entries to allow zone transfers to my backup dns server -
    but when I add the IP in under ISPCONFIG in a given dns entry on the 'allow transfers' config line and save it it does not seem to ever get written back to named.conf.local. only if I go in and manually edit that line do we get the desired result.
    is there a time period? when does ISPCONFIG update the file? did I just not wait long enough?

    I'm curious as I want to allow ALL my zones to transfer to this ip. should I add an allow-transfers into named.conf and would that cover ALL zones??
    currently EACH zone has a allow-transers {none;} line currently.

    or do I need to manually enter all through ISPCONFIG? and if so when is the update written back to named.conf.local?

    or do I need to manually enter them into named.conf.local?

    thanks!
     

Share This Page