ISPCONFIG 3 -Centos 6.4 64bit Nginx squirellmain dovecot mysql mail issue

Discussion in 'Installation/Configuration' started by lewiisf, Sep 10, 2013.

  1. lewiisf

    lewiisf New Member

    Hi all , I am new to this and helping a friend with ISPCONFIG.
    The control panel on the web side is great. All works well, sites are able to perform as needed.
    Problem is with the mail side of things, I can connect with a mail client to the server and it authenticates.
    I can't however see any new mail coming in nor connect via imap to send any mail. I only connect to send via my home isp.
    Checked the mail error log and not seeing any errors come up.

    The webpage for example has a test page for people to subscribe and that doesnt seem to go nowhere, can anybody please assist or offer some guidance to get this mail side of the server working?:eek:

    Webmail doesnt work either, I get a 404 error.:confused:
     
  2. lewiisf

    lewiisf New Member

    more info

    Just in case you guys wanted more info..

    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 localhost:10025 *:* LISTEN 1830/master
    tcp 0 0 *:mysql *:* LISTEN 1687/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 1731/dovecot
    tcp 0 0 *:imap *:* LISTEN 1731/dovecot
    tcp 0 0 *:rockwell-csp2 *:* LISTEN 1443/sshd
    tcp 0 0 localhost:sdr *:* LISTEN 1855/php-fpm
    tcp 0 0 *:ftp *:* LISTEN 1885/pure-ftpd (SER
    tcp 0 0 xxx.com.au:domain *:* LISTEN 1392/named
    tcp 0 0 localhost:domain *:* LISTEN 1392/named
    tcp 0 0 *:smtp *:* LISTEN 1830/master
    tcp 0 0 localhost:rndc *:* LISTEN 1392/named
    tcp 0 0 *:imaps *:* LISTEN 1731/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 1731/dovecot
    tcp 0 0 localhost:cslistener *:* LISTEN 1855/php-fpm
    tcp 0 0 localhost:10024 *:* LISTEN 1754/amavisd (maste
    tcp 0 0 localhost:47946 localhost:mysql ESTABLISHED 1853/amavisd (ch1-a
    tcp 63 0 localhost:45993 localhost:10025 CLOSE_WAIT 1853/amavisd (ch1-a
    tcp 0 0 localhost:mysql localhost:47946 ESTABLISHED 1687/mysqld
    tcp 0 0 xxx.com.au:imap 101.175.73.130:56437 ESTABLISHED 2446/dovecot/imap
    tcp 0 1232 xxx.c:rockwell-csp2 101.175.73.130:58933 ESTABLISHED 1969/sshd
    tcp 0 0 *:pop3 *:* LISTEN 1731/dovecot
    tcp 0 0 *:imap *:* LISTEN 1731/dovecot
    tcp 0 0 *:rockwell-csp2 *:* LISTEN 1443/sshd
    tcp 0 0 *:ftp *:* LISTEN 1885/pure-ftpd (SER
    tcp 0 0 *:smtp *:* LISTEN 1830/master
    tcp 0 0 *:imaps *:* LISTEN 1731/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 1731/dovecot
    [[email protected] ~]#


    [[email protected] ~]# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination
    fail2ban-SSH tcp -- anywhere anywhere tcp dpt:ssh

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    Chain fail2ban-SSH (1 references)
    target prot opt source destination
    RETURN all -- anywhere anywhere
    [[email protected] ~]#
     
  3. lewiisf

    lewiisf New Member

    mail log error

    Seeing this maillog reccuring error.. in /var/log/maillog
    is that any help?


    Sep 10 12:08:01 server1 postfix/smtp[2851]: connect to example.com[93.184.216.119]:25: Connection timed out
    Sep 10 12:08:01 server1 postfix/smtp[2851]: C21B442D10: to=<[email protected]>, relay=none, delay=237978, delays=237948/0.03/30/0, dsn=4.4.1, status=deferred (connect to example.com[93.184.216.119]:25: Connection timed out)
     
  4. lewiisf

    lewiisf New Member

    checked my hosts file

    Checked my host file and seen that there was a wrong ip address.

    This was fixed and restarted,
    For some reason it fixed my mail receiving issue,
    mail log showed messages captured from my website form mail are now going into inbox :)

    Now my issues are using my imap to send mail and get webmail working.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Mails are sent trough postfix (smtp) and not imap. Imap is used to access email that are stored in the maildir of the user.

    Which errors do you get in the mail.log when you connect with imap and smtp to the server?
     
  6. lewiisf

    lewiisf New Member

    Hi thanks for your help.

    I am using outlook and the client won't allow me to connect to the server to send, I can receive emails.
    Error is ...
    Send test e-mail message: Outlook cannot connect to your outgoing (SMTP) e-mail server.

    In /var/log/maillog

    Sep 10 17:30:01 server1 postfix/smtpd[9832]: connect from localhost[::1]
    Sep 10 17:30:01 server1 postfix/smtpd[9832]: lost connection after CONNECT from localhost[::1]
    Sep 10 17:30:01 server1 postfix/smtpd[9832]: disconnect from localhost[::1]
     
  7. lewiisf

    lewiisf New Member

    Ok, i've worked out my isp doesn't allow port 25. I've asked my server hosting provider to open that up as well.

    Thats still not gonna help me, so ill be depending on webmail mosty, however that doesnt work, i get a 404 error.
    Im using nginx, squirellmail.
    Any suggestions there?
     

Share This Page