ISPCONFIG 3 - Centos 5.3 - To many connections

Discussion in 'Installation/Configuration' started by Amorphous, Aug 23, 2009.

  1. Amorphous

    Amorphous New Member

    hello i had the same problem with another server, only this time, it s even worst. i m restarting my server, after 3-4 hours i get the error to many connections, all the mysql databases stop, the acces on the ispconfig stop with the error to many connections .....
    to many connections to what ? i ve deleted all the databases, i ve stopped everything else i had on that server, i haven t made any changes on the server since i installed it, again the same problem with creating new e-mail accounts,
    for the moment i have only 4 e-mail accounts, i m managing 2 domains from ispconfig both mine, and 2 websites ..... that s all ..... i really don t know exacttly what s going on .... please can u help me with something ?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Set:

    max_connections = 500
    max_user_connections = 500

    in mysql my.cnf file.
     
  3. Amorphous

    Amorphous New Member

    sorry doesn t work, same problem
     
  4. Franz

    Franz Member

    Did you restart mysql after modifications?
     
  5. Amorphous

    Amorphous New Member

    trust me .. restarted rebooted the hole system ... tried everything .. i still don t get it .....

    maybe there could be an explanation .... for the moment the server i m keeping ispconfig is an older one, i have only 1 GB ddr in it, and everytime it filles and starts to use the swap, i think there comes the problem also.... could it be connected ??
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Where exactly did you add these to the file? You have do add them in the [mysqld] section and not at the end of the file.

    A "too many connections" error in mysql is only related to this setting.
     
  7. Amorphous

    Amorphous New Member

    is this ok ??
     
  8. Franz

    Franz Member


    Yes it is OK.
     
  9. Amorphous

    Amorphous New Member

    ok i m waiting now to see if anymore problems appear ....

    but one other thing .... as i told u, i havent changed enything, but i have a another problem, i cant make anymore site folders, the isconfig tells me that i added a new site, i create the ftp user for it, but i can t connect to the web folder assigned, i can t see it in the server, it s not created.... also the new mail users, one of the errors i get is something about quota, can u please tell me the commands to see if quota is still working ??? or if there is another p[roblem, can u pls tell the solving solution ? thanks alot
     
  10. Amorphous

    Amorphous New Member

    2009-08-18 17:59 s1far3.freedns.ro Update mail_user


    this is the first job queue not finished yet, everything i m trying to do since this date, is taken to jobqueue, and nothing really materialises :) i really don t understand why, so far everything worked fine ....
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Then you most likely run into problem that is caused by a bug in maildirmake which causes maildimake to hang under certain circumstances which causes the whole queue processing to stop. There is a fix for this problem in ispconfig 3.0.1.4 beta 2:

    http://www.howtoforge.com/forums/showthread.php?t=38495
     
  12. Amorphous

    Amorphous New Member

    so far it seems it s going ok, more or less everithing is correcting itself, seems to be oki :) thanks alot , i havent seen that there were some updates from 3.0.1.3 , and many times i m a bit suspicious about beta releases, but so far it seems to be ok :)



    one small, tiny little problem :)

    i want to make mail.domain.com to show me the real address domain.com/webmail that leads me also to domain.com/webmail/src/login.php


    i want to set the mail.domain.com file exacttly in this place, webmail/src/




    i think i found the location of the src /usr/share/squirrelmail/src/ is this the one ?? if yes plsss guide me now to make the redirection form for mail.domain.com to that location :) thanks alot

    can u please tell me where thi folder is located for centos , and where to change the settings for this location ? i guess something about vhosts but i don t knoe exacttly where is the that manages the vhosts.


    l.e. : i guess i found also the vhost for the mail domain .... /etc/httpd/conf/sites-enabled/mail.domain.com.vhost

    is this the place i have to edit the directoryes ?

    if yes, this is the configuration so far: what i have to change in it ??

    Note: the real domain name is edited by me in this post, for security reasons

    <Directory /var/www/mail.domain.com>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <VirtualHost *:80>
    DocumentRoot /var/www/mail.domain.com/web

    ServerName mail.domain.com
    ServerAdmin webmaster@mail.domain.com

    ErrorLog /var/log/ispconfig/httpd/mail.domain.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/mail.domain.com/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web33/web>
    Options FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all

    # ssi enabled
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Options +Includes
    </Directory>

    # cgi enabled
    <Directory /var/www/clients/client1/web33/cgi-bin>
    Order allow,deny
    Allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /var/www/clients/client1/web33/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web33 client1
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@mail.domain.com"
    php_admin_value upload_tmp_dir /var/www/clients/client1/web33/tmp
    php_admin_value session.save_path /var/www/clients/client1/web33/tmp


    </VirtualHost>


    from my opinion, i have to change at least the documentroot directory to /usr/share/squirrelmail/src right ?? the other options suexec cgi-bin i leave unchanged or i change them as well ??
     
    Last edited: Aug 25, 2009
  13. Amorphous

    Amorphous New Member

    i know i allready crossed the line here with the topics, but i really want to thank you first for all the help till now, and i want also to announce that i managed the problem with the alias :) now it s working great

    just changed the directory location from /var/www/......... to /usr/share/squirrelmail in /etc/httpd/cond.f/sites-enabled/mail.domain.com.vhost and everything is working great :)

    thanks again and sorry for the double posts :)
     

Share This Page