ISPConfig 3 cannot send or receive mail.

Discussion in 'Installation/Configuration' started by bcordrey, Sep 13, 2012.

  1. bcordrey

    bcordrey New Member

    I set up a server with ISPConfig3 on Ubuntu 12.04 for a client using the Perfect Server Tutorial for BIND, Apache, Postfix, and ISPConfig3. Everything except for the mail seems to work fine. I am new to mail on Linux, so I'm not sure what to make of the mail log other than connection problems.

    Here's the link to the pastebin of my mail.log:
  2. falko

    falko Super Moderator ISPConfig Developer

    All I see are connections from localhost. Have you tried setting up an email account in ISPConfig and sending/receiving with an email client such as Outlook or Thunderbird?
  3. bcordrey

    bcordrey New Member

    I've got a test account set up and have been trying to mail between that and a test account I use with gmail.
  4. bcordrey

    bcordrey New Member

    Ok, seeing as how I have no clue what is wrong, and after looking into things a little more, I think there is a serious configuration error somehwere.

    If I telnet to 25 and ehlo localhost, I immediately get disconnected, both locally and remotely. I found a forum stating telnet can't be used with TLS, so I used the command they gave, and ehlo worked fine. I have, as far as I know, all of the proper ports open with ufw. I'm seeing some stuff in my syslog that looks like ufw rejections, so I'm going to put up some pastebins.



    /var/log/mail.log (this is only a portion from this morning, and includes a connection from gmail):

    /var/log/syslog (again, from this morning, and where I see some stuff I don't quite get):

    Also, for a more specific reference, any non-default configuration was done using this Perfect Server How-TO:
    Last edited: Sep 14, 2012

Share This Page