ISPCONFIG 3 breaks Bastille Config file

Discussion in 'General' started by astewart, Sep 16, 2009.

  1. astewart

    astewart ISPConfig Developer ISPConfig Developer

    Why is it that ISPCONFIG 3 doesn't work properly with the Bastille firewall?

    Everything was working fine from the inital ISPCONFIG install on the server, before making any changes to the ISPCONFIG firewall, I was looking at the bastille-firewall.cfg file and it showed the proper ports open:


    Whis is fine.
    So I decide to add a few more ports on TCP through the ISPCONFIG 3, after doing so I had no access to my sites externally.
    So I viewed the bastille-firewall.cfg file again and it looks like it wiped out all the settings:


    What gives?? What is going on here?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which ISPConfig version? There was a bug which has been closed in 3.0.1.4
     
  3. astewart

    astewart ISPConfig Developer ISPConfig Developer

    I am currently running the latest version: 3.0.1.4.

    Is anyone else experiencing this?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Are you sure that you installed the latest version as one of the betas had this bug which was fixed in the final release.
     
  5. astewart

    astewart ISPConfig Developer ISPConfig Developer

    Your right actually, I have the beta version installed on my second server which its not working on.

    I tried re-running the ispconfig upgrade, selected STABLE but it already said I have the latest version installed which I don't.

    Is there a way around this without having to uninstall ISPCONFIG?
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

  7. astewart

    astewart ISPConfig Developer ISPConfig Developer

Share This Page