ispconfig 3 and zencart

Discussion in 'Installation/Configuration' started by chief, Apr 8, 2012.

  1. chief

    chief Member

    Hi all,
    background first..

    I have running, a new ispconfig ver 3, i have 4 websites running wordpress, 8 running other pre built stuffs.

    I am migrating from my older ispconfig 2 server, everything worked fine until zencart 1.50 came out forcing an upgrade.
    It needed new version of php, was 1 version behind
    I decided to build new server, test then move each site across, also have mail server on same machine as well running mail for 3 domains currently.
    By the way, old server was running 20 sites with mail quite happily.
    ok to the problem

    did a new build of 1.50, created template for client all working pukka, go live with new site on new server.
    I cannot login, do reset via email. email wont leave server.
    update email to domain on server, still wont leave.
    do new install inside domain/new/ and it works fine, can mail out to gmail can mail to hosted domain. ok cool i thought.
    went through exporting each table from phpmyadmin and importing on old version, at the end it still didnt work.
    moved old site to back dir and moved new install to route of domain and the same problem occurs. site works, cannot login, can update password via phpmyadmin, try and login but still refuses. logon screen comes back up everytime then tells me too many unsuccesful logins come back 15 mins later.
    ispconfig 3 has a few setting s for php - tried them all.
    1. php disabled
    2. fast-cgi
    3. cgi
    4. mod-php
    5. suphp
    and tick box for suexec

    i also reset permissions to 755 and then back to 777 as 755 didnt work on folders, all files are 644.
    the strange thing is if i put zencart in sub folder it works

    any suggestions

  2. falko

    falko Super Moderator ISPConfig Developer

    Did you check your logs?

    Did you check with
    that your new PHP version is working properly?
  3. pititis

    pititis Member

  4. chief

    chief Member

    thanks for the reply,

    will check the logs, although i have been monitoring them, when i was sending an email reset i was using tail -f /var/log/maillog . php was not sending anything.
    In my new install of zencart it was sending and leaving a log, but when i moved the new install to the domain root the issue happened again, move it to a sub folder ie /new/ it starts to work.

    I have got around the problem currently by moving site to /catalog/ and having an index.html which forwards everything to the catalog directory.

    pititis, i have done a fresh install of fedora 15, fresh install of ispconfig 3, and copied the websites from 1 server to another. for the email's i used imapsync to send emails from 1 server to other. it keeps everything and works a treat.


Share This Page