ISPconfig 3 and nginx

Discussion in 'General' started by Norman, Apr 15, 2012.

  1. Norman

    Norman HowtoForge Supporter

    Been trying nginx and ispconfig 3.
    I just cant seem to get it to work.

    Setup a site as usual.
    Tried a simple test.php <?php phpinfo(); ?> and that displays properly.

    But if I unzip a standard wordpress installation I just keep getting error 500.
    Nothing in the logs at all.

    Just resource temporarily unavailable.

    Setup is based on the howtoforge guide with Debian 6, nginx + php5-fpm from dotdeb.
    Any idea what may cause this? Known issue?
     
  2. Norman

    Norman HowtoForge Supporter

    Found the issue. Turns out in the php version that debian and ubuntu uses short php tags isn't supported by default. One of the scripts had a short php tag.


    However, I have another issue.
    If a php script takes a long time to load (long DB query) and times out and delivers whatever data has been processed so far.
    Any new php query on that worker will just return error 500 until the php5-fpm is restarted.

    Anyone have an idea what may be the cause of this?
     
  3. falko

    falko Super Moderator

    Have you tried the fastcgi_read_timeout directive? You can put it into /etc/nginx/fastcgi_params (e.g. with a value of 240 (= 4 minutes)).
     

Share This Page