Ispconfig 3 and created zones dns

Discussion in 'General' started by r4faga, Dec 9, 2011.

  1. r4faga

    r4faga Member

    Is something wrong with a creation zones dns on ispconfig 3?? i mean when i created one zone to my domain (domain.com), ispconfig 3 created this:
    A example.com. 5.6.7.8 0
    A mail 5.6.7.8 0
    A www 5.6.7.8 0
    MX example.com. mail.example.com.. 10
    NS example.com. ns1.mydomain.com. 0
    NS example.com. ns2.mydomain.com. 0

    i created on my domain panel a registres type a ns1.domain.com and ns2.domain.com. But i used intodns.com and show me this.

    Category Status Test name Information

    Parent

    TLD Parent Check: WARNING: Looks like the parent servers do not have information for your TLD when asked. This is ok but can be confusing.

    DNS Parent sent Glue: The parent nameserver ns1.cctld.co is not sending out GLUE for every nameservers listed, meaning he is sending out your nameservers host names without sending the A records of those nameservers. It's ok but you have to know that this will require an extra A lookup that can delay a little the connections to your site. This happens a lot if you have nameservers on different TLD (domain.com for example with nameserver ns.domain.org.).

    NS

    NS records from your nameservers: NS records got from your nameservers listed at the parent NS are:
    Oups! I could not get any nameservers from your nameservers (the ones listed at the parent server). Please verify that they are not lame nameservers and are configured properly.

    Mismatched NS records: WARNING: One or more of your nameservers did not return any of your NS records.

    Same Glue: Hmm,I do not consider this to be an error yet, since I did not detect any nameservers at your nameservers.

    Mismatched NS records: WARNING: One or more of your nameservers did not return any of your NS records.

    DNS servers responded ERROR: One or more of your nameservers did not respond:
    The ones that did not respond are:
    1.2.3.4 (1.2.3.4 is my ip ns record)

    Multiple Nameservers: ERROR: Looks like you have less than 2 nameservers. According to RFC2182 section 5 you must have at least 3 nameservers, and no more than 7. Having 2 nameservers is also ok by me.

    Nameservers are lame ERROR: looks like you have lame nameservers. The following nameservers are lame:
    1.2.3.4 (1.2.3.4 is my ip ns record)

    Missing nameservers reported by your nameservers You should already know that your NS records at your nameservers are missing, so here it is again:

    NS1.mydomain.com.
    NS2.mydomain.com.

    SOA

    SOA record No valid SOA record came back!

    MX Records Oh well, I did not detect any MX records so you probably don't have any and if you know you should have then they may be missing at your nameservers!

    WWW A Record Your www.myexample.com A record is:
    www.myexample.com [5.6.7.8] (5.6.7.8 is my ip public).

    I dont modify nothing, i just created with ispconfig panel and registre ns1 and ns2, and on my domain panel to. My website is see on ww.example.com, but i cant resolve if i type example.com, i send emails but i cant receive. If i type nslookup MX
    Server: 5.6.7.8
    Address: 5.6.7.8#53

    Non-authoritative answer:
    *** Can't find MX: No answer

    and

    nslookup ns
    Server: 5.6.7.8
    Address: 5.6.7.8#53

    ** server can't find ns: NXDOMAIN


    Any help, i mistake something??

    :-S
     
  2. Ghostdare

    Ghostdare Member

    That is a lot of text there so I got confuse in it. This is the DNS from one of my site maybe it will help you.

    A balamalele-subrede.ro. 193.254.235.4 0
    A beta 193.254.235.4 0
    A mail 193.254.235.4 0
    A ns 193.254.235.4 0
    A www 193.254.235.4 0
    CNAME balamalele-subrede.ro www 0
    MX balamalele-subrede.ro. mail.balamalele-subrede.ro. 10
    NS balamalele-subrede.ro. ns.balamalele-subrede.ro. 0

    Don't forget the dot after... i've mark them with red colour.
     
    Last edited: Dec 10, 2011
  3. r4faga

    r4faga Member


    Hi men, thanks for you help, i show my config of my records on my ispconfig panel, but if i get intodns.com (is a tool), he show me a several erros, i cannot receive email, i can send them but i cant receive. on intodns.com show me a error about MX, but i created on my ispconfig panel, a question is, i have to do something more on my ispconfig panel?? or i have to created something record on my domain panel control??? on my domain panel control i just created a record type A so redirect on my ip public, but i dont know if i have to created another record.

    Thanks.
     
  4. Ghostdare

    Ghostdare Member

    So give me your domain name.... if you don't want to post it here, PM me, I just want to see the errors displayed with my own eyes.
     
    Last edited: Dec 12, 2011
  5. Ghostdare

    Ghostdare Member

    OK so i've checked your domain. You have problem with your NameServers.

    First:
    Your NS16.ZONEEDIT.COM doesen't respond .... seems to be down
    Your NS14.ZONEEDIT.COM it's up .... but it second - you should put it first.

    Second:
    You dont control your zones from ISPConfig control panel.. those records must be added at zonedit.com.

    Later edit:
    If you want to control your DNS zones.... create at your domain registar with your own NS (Ex: ns1.yourdomain.com and ns2.yourdomain.com), of course if you have an static IP. Create this NS record in ISPConfig and the rest of your DNS records (A, MX, CNAME, etc...).


    If you are confused, try to buy Till's and Falko manual for ISPConfig it's only 5 Euro.
     
    Last edited: Dec 12, 2011
  6. r4faga

    r4faga Member

    Thanks ghostdare, i ll try to fixed i changed ns, i dont saw it that only one work, when do you said that i cant control my zones with ispconfig, you mean dont created any record?? just i have to created a records on zoneedit?

    Dam sorry i feel like a noob on this.
     
  7. Ghostdare

    Ghostdare Member

    Yes. DNS zone must be added at zonedit.com. If you create your own NS then the zones created in ISPConfig will work.
     
  8. asterinux

    asterinux New Member

    why is it that when i create a zone file in ISPConfig 3, it will create a zone with a priv prefix? eg: priv.domain.com
     
  9. falko

    falko Super Moderator ISPConfig Developer

    The prefix should be pri, not priv. "pri" stands for primary (nameserver).
     

Share This Page