ISPconfig 3 and centos 5.6 doesn't start

Discussion in 'Installation/Configuration' started by giuly, Jan 6, 2012.

  1. giuly

    giuly New Member

    Hello I try to install on a server with centos 5.6 all the packages in guide perfect server, and so all packages included ispconfig, all other packages works well, but not ISP config that doesn't start if I insert on web browser my ip:8080

    I don't have domain, but only a ip address
    so
    95.xxx.xxx.xxx
    I don't know if I had wrong thing in file hosts but
    I see correctly
    phpmyadmin on browser
    I see correctly
    squirrelmail on browser
    but if i enter
    95.xxx.xxx.xxx:8080 or with /
    it doesn't start
    please any advice
    I see a blank white page...
     
    Last edited: Jan 6, 2012
  2. giuly

    giuly New Member

    I add a information, miss on my server on init.d the ispconfig???
    So system didn't start
    please how have I to do?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Please restart Apache and then check if Apache is listening on port 8080:
    Code:
    netstat -tapn
     
  4. giuly

    giuly New Member

    thanks
    no it isn't port 8080

    I try to add
    Listen 8080
    on httpd.conf and then restart apache, but now I see html page... not page of ispconfig
     
    Last edited: Jan 7, 2012
  5. giuly

    giuly New Member

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
    tcp        0      0 127.0.0.1:199               0.0.0.0:*                   LISTEN      2682/snmpd          
    tcp        0      0 0.0.0.0:903                 0.0.0.0:*                   LISTEN      2417/rpc.statd      
    tcp        0      0 127.0.0.1:10024             0.0.0.0:*                   LISTEN      3076/amavisd (maste 
    tcp        0      0 127.0.0.1:10025             0.0.0.0:*                   LISTEN      3133/master         
    tcp        0      0 0.0.0.0:49258               0.0.0.0:*                   LISTEN      3364/java           
    tcp        0      0 127.0.0.1:3310              0.0.0.0:*                   LISTEN      2790/clamd          
    tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      2368/portmap        
    tcp        0      0 0.0.0.0:10000               0.0.0.0:*                   LISTEN      3480/perl           
    tcp        0      0 0.0.0.0:21                  0.0.0.0:*                   LISTEN      2777/vsftpd         
    tcp        0      0 95.110.232.194:53           0.0.0.0:*                   LISTEN      2338/named          
    tcp        0      0 127.0.0.1:53                0.0.0.0:*                   LISTEN      2338/named          
    tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      3133/master         
    tcp        0      0 127.0.0.1:953               0.0.0.0:*                   LISTEN      2338/named          
    tcp        0      0 0.0.0.0:3071                0.0.0.0:*                   LISTEN      3364/java           
    tcp        0      0 127.0.0.1:39598             127.0.0.1:21                TIME_WAIT   -                   
    tcp        0      0 127.0.0.1:52562             127.0.0.1:80                TIME_WAIT   -                   
    tcp        0      0 :::3306                     :::*                        LISTEN      3026/mysqld         
    tcp        0      0 :::34571                    :::*                        LISTEN      3443/java           
    tcp        0      0 :::34572                    :::*                        LISTEN      3443/java           
    tcp        0      0 :::80                       :::*                        LISTEN      10241/httpd         
    tcp        0      0 :::53                       :::*                        LISTEN      2338/named          
    tcp        0      0 :::22                       :::*                        LISTEN      2744/sshd           
    tcp        0      0 ::1:953                     :::*                        LISTEN      2338/named          
    tcp        0      0 :::443                      :::*                        LISTEN      10241/httpd         
    tcp        0   2352 ::ffff:95.110.232.194:22    ::ffff:93.56.115.194:58372  ESTABLISHED 9497/sshd: adminp10 
    tcp        0      0 ::ffff:127.0.0.1:51649      ::ffff:127.0.0.1:25         TIME_WAIT   -                   
    
    
    
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Did you see any errors during the ISPConfig installation? What's the output of
    Code:
    ls -l /etc/httpd/sites-available/
    ?
     
  7. giuly

    giuly New Member

    Code:
    ls -l /etc/httpd/sites-available/
    ls: /etc/httpd/sites-available/: No such file or directory
    
    no I didn't see any error during installation
    and I see my site digiting my ip address of server
    :(
     
  8. Bakhytbek

    Bakhytbek New Member

    ISPconfig 3.0.4.3 on Debian 6.0

    Hello!
    My problem is exactly the same as described in this topic.

    I started with Debian 6.0 with Apache and Bind preinstalled on VDS, so fisrt two pages of perfect Debian Squeeze manual was skipped. I followed rest of this manual precisely, excluding last question about secure control panel access (my answer was 'yes').

    I have no domain name, just IP address, so just after reboot I tried to access "IP:8080" with my browser with no results: blank page for about half-minute, and "try again later" after.

    When just IP used (without 8080), I can see default apache "It works" page.


    Please help! Can't figure out what am I doing wrong.

    Here is some additional information:

    I have these lines in "netstat -tapn":
    Code:
    tcp    0    0 0.0.0.0:8080    0.0.0.0:*    LISTEN    1786/apache2    
    tcp    0    0 0.0.0.0:80       0.0.0.0:*    LISTEN    1786/apache2  
    tcp    0    0 0.0.0.0:8081    0.0.0.0:*    LISTEN    1786/apache2
    
    Result of "iptables -L"
    Code:
    Chain INPUT (policy ACCEPT)
    fail2ban-ssh         tcp  --  anywhere  anywhere  multiport dports ssh 
    fail2ban-pureftpd  tcp  --  anywhere  anywhere  multiport dports ftp 
    fail2ban-dovecot-pop3imap  tcp  --  anywhere  anywhere multiport dports pop3,pop3s,imap2,imaps 
    
    Chain FORWARD (policy ACCEPT)
    
    Chain OUTPUT (policy ACCEPT)
    
    Chain fail2ban-dovecot-pop3imap (1 references)
    RETURN     all  --  anywhere             anywhere            
    
    Chain fail2ban-pureftpd (1 references)
    RETURN     all  --  anywhere             anywhere            
    
    Chain fail2ban-ssh (1 references)
    RETURN     all  --  anywhere             anywhere 
    
    /etc/apache2/sites-enabled contains symlinks to:
    Code:
    000-apps.vhost
    000-default
    000-ispconfig.conf
    000-ispconfig.vhost
    
    Apache configuration files are here

    Update:

    'wget localhost:8080' brings me HTML of ISPconfig login page, so all what i need is access from outside.
     
    Last edited: Mar 7, 2012
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    If there is a router or firewall between your computer and your server, then open port 8080 to get access to ispconfig.
     
  10. Bakhytbek

    Bakhytbek New Member

    Thank you for fast reply!

    I tried to disable iptables and stop bastille-firewall (bundled with ISPconfig) but still no access. I also disabled my personal firewall on my local machine, and there are no restrictions in my home router's firewall. I don't know what settings my VDS hosting provider using, and I don't know how to trace this. Maybe you can help if I provide you IP of my online server?
     
  11. Bakhytbek

    Bakhytbek New Member

    Must read answer twice before asking new one

    @till
    Sorry for the stupid questions please.
    I first had to fully understand the answer to the first, and then ask the second.
    The cause was a hardware firewall of my hosting provider.
     
  12. popsof3

    popsof3 New Member

    Same problem, did you solve?

    Did you ever solve this? I am having the exact same problem on CentOS 5.7. If you could tell me your solution I would be grateful!

    It seems like ISPConfig didn't install into Apache and so nothing is listening on 8080....just like what you describe. Hopefully you have solved and can help me! Thanks!

     
  13. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    iptables -L
    ?
     

Share This Page