ISPConfig 3.2 + Softaculous + InvoiceNinja 5

Discussion in 'Installation/Configuration' started by 3volve-karl, Mar 15, 2022.

  1. 3volve-karl

    3volve-karl New Member

    Good day guys,

    Thank you so much for this amazing platform, if someone can contact me about the criteria to become a sponsor.

    I setup ISPConfig 3.2 on a Debian 11 email. I loaded Softaculous, and I have used Softaculous to install Invoice Ninja 5 (latest) on to my server.

    The files all install into /var/www/client(x)/web(x)/web and the symbolic links /var/www/client(x)/sub,domain.tld and /var/www/sub,domain,tld or pointing correctly.

    All the files appear to be there but when I open the site at sub.domain.tld it just opens the default index.html, even though the html file is not existing in the root web folder.

    I am running PHP-FPM and PHP7.3 for the site.

    I also have all other scripting engines enabled as well for the site.

    I doubt it is a Softaculous issue, as the files all loaded. I am not sure if it is something I need to check on ISPConfig (a possibl ID10T error )

    Any pointers will be a help.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    3volve-karl likes this.
  3. 3volve-karl

    3volve-karl New Member

    I could kick myself in the gonads. That makes absolute sense and I now wish I had read that post first. Was just in a rush to get out the office.

    Thank you for giving the guidance without a long winded work around.

    I now know that most issues can be resolved in this one post, I am printing it as my "cheat sheet"

    1000 Thank yous.
     
    till likes this.
  4. 3volve-karl

    3volve-karl New Member

    Feedback:

    We installed Invoice Ninja without the HTTPS option enabled as I am using SSL on the route domain via another server. Since we are using a subdomain on this domain.tld, I am still having to read up and figure out how to run more than one SSL certificate on the same domain.tld. Due to time constraints that is a problem for another day.

    However, disabling SSH solved the issue instantly. Also learned that the latest version of Ninja now needs PHP7.4.

    Just making this note for reference for others. I find it very annoying when finding a post online explaining a problem and then it ends with "Solved!" with no explanation of how it was solved. Hope others find this thread useful.

    Once again, thank you.
     
    till likes this.

Share This Page