ISPConfig 3.2 multiserver issue

Discussion in 'Installation/Configuration' started by sheshes, Nov 11, 2020.

  1. sheshes

    sheshes Member

    I have updated ISPconfig to 3.2 stable on my multiserver setup and all went well, when today after apt updates and linux headers updates pure-ftp is running but not listening on port 21 or on either port.

    I tried rerunning the ispconfig_update.sh script to reconfigure services but is says that DOWNGRADING is dangerous. This is a problem as I have the stable version up and running on my production setup and this could possibly mess up future updates. Plus I cannot run the update process again to reconfigure the services and get my ftp service back on.

    Please advise
     
  2. ahrasis

    ahrasis Well-Known Member

    Instead of using the script, update manually.
     
  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You can run the update script manually with these commands:
    Code:
    cd /tmp
    wget https://www.ispconfig.org/downloads/ISPConfig-3.2.tar.gz
    tar xvfz ISPConfig-3.2.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    And then reconfigure services.
     
  4. sheshes

    sheshes Member

    tried reconfiguring with manual update no luck. tried stopping and restarting, everything starts fine but doesn't listen to port 21 so the monitor of ISPconfig show error.
     
  5. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Take a look at the pure-ftpd log and status to see if any error is logged.
     
  6. sheshes

    sheshes Member

    Problem Solved. Apparently the ispserver.pem didn't update correctly and needed to be fixed.
     

Share This Page