ispconfig 3.2.7p1 - autoinstall script

Discussion in 'Installation/Configuration' started by 5t3f4n, Oct 23, 2021.

  1. 5t3f4n

    5t3f4n New Member

    hello, good morning

    following the the 'Perfect Multiserver Tutorial', step 6 'Installing the first Nameserver' using Debian 10.
    The ISPConfig autoinstaller throws a warning after step 'Configure DNS Server (y,n) [y]: <-- Hit Enter'.
    Code:
    [WARN] autodetect for PowerDNS failed
    the install i continued with confirming 'y' for PowerDNS and 'y' for subsequent warnings
    Code:
    Force configure PowerDNS (y,n) [n]: y
    
    [WARN] autodetect for BIND failed
    Force configure BIND (y,n) [n]: y
    
    [WARN] autodetect for MyDNS failed
    Force configure MyDNS (y,n) [n]: y
    
    Configuring PowerDNS
    Configuring BIND
    then a php warning is shown, followed by 'Configuring MyDNS'
    Code:
    PHP Warning:  chgrp(): Unable to find gid for bind in /tmp/ispconfig3_install/install/lib/installer_base.lib.php on line 2159
    Configuring MyDNS
    after this section the auto-install continues as per tutorial with:
    Code:
    The Web Server option has to be enabled when you want run a web server or when this node shall host the ISPConfig interface.
    Configure Web Server (y,n) [y]: n
    the warnings are an issue for the set-up or not, can someone please assist?

    thanks!

    OS
    Code:
    [email protected]:~# lsb_release -a
    No LSB modules are available.
    Distributor ID:    Debian
    Description:    Debian GNU/Linux 10 (buster)
    Release:    10
    Codename:    buster
    php version
    Code:
    [email protected]:~# php -v
    PHP 7.3.31-1+0~20210923.88+debian10~1.gbpac4058 (cli) (built: Sep 23 2021 22:03:28) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.3.31, Copyright (c) 1998-2018 Zend Technologies
        with Zend OPcache v7.3.31-1+0~20210923.88+debian10~1.gbpac4058, Copyright (c) 1999-2018, by Zend Technologies
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is not using PowerDNS, it uses BIND. So the warning was perfectly OK, nothing to worry about and you should have not chosen yes there.

    This means you probably logged in as root in the wrong way. If you login on Debian 10 as other user than root, then you must use 'su -' to become root, if you would use just 'su' without the '-', then su loads the PATH variable in the wrong way. See chapter 6, it explicitly states that you must use 'su -' on Debian 10. That's why the installer was not able to detect services correctly.

    There you should have chosen 'n'

    For a DNS node, choose 'n' there, as described in the guide.
     
  3. 5t3f4n

    5t3f4n New Member

    ok, thanks for this!

    will do a clean re-install - how can i wipe the ns1 settings from the existing ISPConfig set-up ... delete ns1 records via sql, perhaps a guide exists?

    thanks
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no need to reinstall. just disable symlinks to powerdns plugin in the folder /usr/local/ispconfig/server/plugins-enabled/
     
    5t3f4n likes this.
  5. 5t3f4n

    5t3f4n New Member

    solved - thanks! :)
     

Share This Page