ISPConfig 3.1 multiserver (according to manual)

Discussion in 'ISPConfig 3 Priority Support' started by rica5736, Nov 10, 2016.

  1. rica5736

    rica5736 New Member HowtoForge Supporter

    Hi.
    I have enourmus problems with the multi server setup.
    I'm doing exactly as the manual say. But clean up the terminal commands from the  and makes the apt-get commands in one line.
    And the IP correct in mysq commands in the web setup.


    The OS I've tried to make the setup work is Debian 8.1 and 8.5 in a viritual environment.

    Problems I have:
    First setup did the crons not executable. And the phpmyadmin stoped working.

    Later I've did a some new setups (4times)
    But with these problems.

    Web... goes ok in installation until access to the phpmyadmin wich is inaccessible 3 of 4 times.

    DB.... Can't access or populate the master DB
    Ns1 and ns2 same there. 2 of 4 times.

    In the xaamp install it cannot access the git at all.

    My first "successful" install it started to go really really slow until phpmyadmin and ISPConfig stoped work completely.

    My last install I've shorten down my MySQL root pwd to 15 letters/numbers from my initial 30. I've even tried 8 letters/numbers but all the same.

    I've even tested more and multiple cores from 1-10 and from 0,5-16 Gb ram on each instance if it where performance related.

    One question I have other than to solve these problems is. If I do a single server setup at first and then adds the rest of the servers later just to get started. Is it possible to populate the info on to the new servers from the single server?


    Best regards /Rikard
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There are no known issues with that setup, we use it for years in this way since the early ispconfig 3.0 versions.
    Looks as if either your master server is running unstable so that mysql dies or the network is unstable.

    You can start with a single server (perfect server tutorials) and add additional servers to that later so that it becomes the master server. But websites, mail accounts etc. that you create on that server will stay there, you can not move them to the additional servers later without deleting them first. Only new websites or mail domains etc. can be placed on the additional servers.
     
    rica5736 likes this.
  3. rica5736

    rica5736 New Member HowtoForge Supporter



    Guessing there is some problem with my setup then. Is there any reports on problem with openstack? Cloudinit/cloudconfig?

    The manual puts  and breaks the lines on some places it this correct?

    I try to do one more setup without the openstack.

    I got floating IP (external) can this make some problems?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I'm not aware of any reports regarding that VM environment. Personally I did not use that yet.

    There should be no  in commands and do not add linebreals e.g. in apt commands. You should see on the screen when there is a problem as all commands must finish without an error.

    You should ensure to use the fixed internal IP addresses in the hosts files on all servers so that they can connect to each other by the fixed IP. If MySQL on the master is not able to resolve the hostname of a slave correctly, then it will deny access, that's why the manual recommends to add hosts files on all nodes which contains all other nodes of the multiserver system to ensure consitant name lookups.
     
    rica5736 likes this.
  5. rica5736

    rica5736 New Member HowtoForge Supporter

    Finally solved it.. it was the open stack config files. did a new image exactly as the manu. but added the floating IP in the interfaces. Now Finally.
     
    till likes this.

Share This Page