ISPConfig 3.1 - min. required PHP version

Discussion in 'Developers' Forum' started by till, Dec 7, 2015.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    We plan to raise the min. required PHP version for the ISPConfig UI and server part from PHP 5.2 to PHP 5.3 with the ISPConfig 3.1 release. This allows us to clean up the code and remove workarounds for PHP 5.2. PHP 5.3 is available for the still supported Centos 6 and Ubunru LTS versions, so I don't see any problem here to raise the min. version.

    If you have any comments on why we can't raise the PHP min version to 5.3, then please let me know.
     
    Nemis likes this.
  2. Jesse Norell

    Jesse Norell Active Member

    Looks like debian 5 had php 5.2 as well. Not that my "vote" counts for much, and I have no legacy systems to maintain here, but dropping support for very dated systems sounds like a perfectly acceptable (even good) thing.
     
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    i would _never_ run debian lenny on a production server. debian lenny was replaced in 2012 with squeeze. If someone really wants to stay with such an outdated os:
    use dotdeb to get php5.x
    compile your own php
    stay with 3.0.5.4
     
  4. brody182

    brody182 Member

    php 5.4 should be the minimum.
     
  5. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    5.4 as a minimum won´t work - see #1 ;)
     
  6. brody182

    brody182 Member

    you should look at the current OS distributions today, centOS 7, Debian 8, etc. php 5.4 is the minimum requirement. Nobody in their right mind will install an outdated OS from 3 years go. IF they want php 5.2, 5.3 They should sitck with ispconfig 3.0
     
  7. brody182

    brody182 Member

    you have to move forward not backwards
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Nobody will install an old OS on a new server, but there are plenty of installs on current servers and e.g. CentOS 6 is still supported with security updates by CentOS, so it is not outdated yet and it comes with PHP 5.2 by default and there is an option to install 5.3, so switching to 5.4 will break a lot of old installations and therefore, we can't switch to 5.4 yet.
     
  9. rst

    rst New Member HowtoForge Supporter

    I (partially) agree with brody182. It is very noble that you as ISPConfig developers still try to support such old PHP versions, but this makes quite some stuff more difficult to do. Also take in mind that official PHP support for even 5.4 has already ended.

    I think making new features only available for newer PHP versions would be reasonable. People who don't wish to update their PHP versions, can continue running on their current ISPConfig version.

    Do you happen to have any statistics available on server configurations using ISPConfig? That could make this discussion a bit less theoretical...
     
  10. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Debian 6 comes with 5.3.3

    We are NOT talkinig about min. PHP 5.4 or 5.5 - the question is (was): anyone really needs 5.2
     
  11. Drakia

    Drakia New Member

    Just a heads up, it looks like the following files break PHP 5.3 support (PHP 5.3 doesn't support accessing an array directly from the return value of a function):
    (Line numbers are based on the stable-3.1 branch)
    ./server/plugins-available/mail_plugin.inc.php (Lines 209 and 458)
    ./interface/web/sites/database_quota_stats.php (Lines 60 and 76)
    ./server/plugins-available/mongo_clientdb_plugin.inc.php (Line 263)

    The mail_plugin.inc.php error actually caused the updater to fail halfway through.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Thank you for your findings. I'll check that.
     

Share This Page