ISPconfig 3.1 Installation / Upgrade

Discussion in 'Developers' Forum' started by geraldm, Jan 15, 2016.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, there will be a new manual for 3.1 that covers the new ui, all new functions and some extra chapters to xplain how ispconfig works internally, the directory structure etc.
     
  2. budgierless

    budgierless Member HowtoForge Supporter

    thanks thats good to know, im looking forward to using isp3.1 with ubuntu 16.04LTS.
     
  3. DDArt

    DDArt Member

    Same here, been waiting and still waiting to upgrade and migrate some 14.04 and 15, to a new 3.1 and another LTS Ubuntu
     
  4. harshu294

    harshu294 Member

    After updating to ISP config 3.1. We are getting below mentioned error during updation of slave server

    Updating Crontab
    Restarting services ...
    Update finished.
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 21: -d: command not found
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: syntax error near unexpected token `else'
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: `else'
    /usr/local/bin/ispconfig_update.sh: line 4: ate.php: command not found

    Also, find the screenshot of error (error.gif) of web interface . which we are getting when we saw the monitoring section.
    Please note this error is regarding over salve server.
    Master is not showing any error error.gif
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    https://git.ispconfig.org/ispconfig/ispconfig3/issues/4227

    You missed to set the main server in maintenance mode, so someone made changes in ispconfig while not all servers were updated and the change could not be replicated to the slave as the slave was still 3.0.5 version and not 3.1.
     
  6. harshu294

    harshu294 Member

    Hi,
    I want to setup a primary and secondary DNS on ISP config3.1 with centos 7.2
    I followed below mentioned document
    https://www.howtoforge.com/how-to-r...and-secondary-with-ispconfig-3-debian-squeeze

    But now i m not able to make it.

    I also tried installing older version. But it is not working.
    I m not getting below option while installing ispconfig on Primary and secondary

    Shall this server join an existing ISPConfig multiserver setup (y,n) [n]:

    Does ISP config 3.1 support multiserver(pri. and sec. DNS) support on centos 7.2?
    if yes then which document i should follow ?
     
    Last edited: Oct 3, 2016
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to run the installer in expert mode, then you get this question. The installer asks if you want to run it in standard or expert mode.

    Sure, thats supported off course in CentOS, Debian and Ubuntu.
     
  8. Jesse Norell

    Jesse Norell Well-Known Member

    Should some maintenance mode logic be added to the install/update script? For single servers just enable at the start, disable at the end. For multi-servers, the master could enable maintenance mode at the start, then when it detects there are slave servers just prompt the user whether it should keep maintenance mode enabled or not (and if it's enabled, you manually disable it when done updating slaves).
     
  9. harshu294

    harshu294 Member

     
  10. harshu294

    harshu294 Member

     
  11. harshu294

    harshu294 Member

    I want to upgarde from ISP config 3.0 to 3.1 .Kindly let me know the exact steps involved for multiple server setup.
    Please note i am using ISP config 3.0 for DNS(pri and secondary).
    Please treat this urgent.
     
  12. harshu294

    harshu294 Member

    Also you told to keep master in maintance mode. is it mean that i should boot master server in single user mode?
     
  13. Jesse Norell

    Jesse Norell Well-Known Member

    No, that means to enable maintenance mode within ispconfig before you start updating. You'd update the master server first, then all your slaves, and finally turn maintenance mode off.
     
  14. tamaga

    tamaga New Member

    Hallo Till, leider habe ich nach dem Update von 3.0.5.4p9 auf 3.1.1p1 kein Login mehr möglich, es kehrt immer wieder zum Login zurück.
    Ich habe parallel Apache und nginx laufen. Irgend eine Idee wo ich nachschauen kann.
     
  15. tamaga

    tamaga New Member

    Ok, hat sich erledigt lag am Browser Cache.
     
  16. BruFFy

    BruFFy New Member

  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Check if mysql / mariadb is running.
     
  18. BruFFy

    BruFFy New Member

    Yes it's running
    It wouldn't log my auth if it didn't.
    I did the same install with apache (i've read that, that one worked for sure) but I have the same problem.
    https://www.howtoforge.com/tutorial...pureftpd-bind-postfix-doveot-and-ispconfig/3/
    I also tried the fix... $cookie_domain = (isset($_SERVER['SERVER_NAME']) && $_SERVER['SERVER_NAME'] != '_') ? $_SERVER['SERVER_NAME'] : $_SERVER['HTTP_HOST'];
    without succes :(
     
    Last edited: Jun 12, 2017
  19. BruFFy

    BruFFy New Member

    ispconfig3-stable-3.1-f3445b33ae6f4e2c91501591531d90643aade4b2 fixed it
     

Share This Page