ISPConfig 3.1 - how to configure and use xmpp?

Discussion in 'General' started by rodrigosarri, Sep 29, 2017.

  1. rodrigosarri

    rodrigosarri New Member

    Hello, I bought the ISPConfig manual and followed the steps to configure XMPP, however, I still can not ping port 5222 (default for xmpp) and without a way to connect to the server.
    Here are the steps and configuration I did:

    1 - First I activated XMPP through the Server System menu and I checked the XMPP Server option
    2 - And then I went to email XMPP domains
    3 - I selected the client and put the domain as: universos.io, I checked the active option. On the SSL tab, I filled in the required fields and selected the add certificate option and clicked save
    4 - After performing the processes, I returned the SSL tab option and chose the save certificate action and clicked on save again
    5 - I downloaded the xmpp pidgin client and followed the steps to add the server: I added a new account by selecting the xmpp protocol and populating the username, domain and resource and the result was failed to connect to the server
    6 - I accessed my server through SSH and I made a telnet myserver 5222, 5223, and the ports did not respond, I searched a lot and found no solution, can you help me?

    Thanks
     
  2. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

    uhm I don't like to say that but: I haven't bought the book, sry @till *hug
    so I don't know wether it is described how to install the expected metronome sevrer instance.
    like described for debian 9 in https://www.howtoforge.com/tutorial...-9-stretch-apache-bind-dovecot-ispconfig-3-1/
    for example?

    If so, are there any hints on the logs why the service didn't start maybe?
    Are you running some firewall-scripts which have a DENY-policy where you have to open ports you need?


    btw. if I had time I'd so add https://jitsi.org/ to that ^^ or you could combine the video-part with ejabberd ....
     

Share This Page