ISPConfig 3.1 and Joomla 3.7.2 with PHP 7.1

Discussion in 'General' started by onastvar, May 25, 2017.

  1. onastvar

    onastvar Member

    Hi,
    For one of the sites using Joomla in ISPConfig I changed PHP from default PHP to PHP 7.1
    Here are the settings:

    PHP: Fast-CGI
    PHP Version 7.1.0
    Apache/2.4.10 (Debian)
    WebServer to PHP Interface cgi-fcgi
    Joomla! Version
    Joomla! 3.7.2 Stable [ Amani ] 22-May-2017 09:46 GMT

    I get this error:
    Error displaying the error page: The memcache Cache Storage is not supported on this platform.: The memcache Cache Storage is not supported on this platform.

    Only answers I found was to make /administrator/cache folder writable - did not work. Do you think this is related to joomla, php or ispconfig?
     
  2. ahrasis

    ahrasis Active Member

    Have you check this out?
     
  3. onastvar

    onastvar Member

    Thanks for your reply ahrasis!

    I did check that link before I posted.
    All joomla folders are writable except file configuration.php which shouldn't be.

    I ran: chown -R web8:client8 /var/www/clients/client8/web8/web/
    still same error

    Any other ideas, anyone?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks to me as if the PHP 7.1 that you use does not has memcache support compiled in. Put a php file with phpinfo() command into the web and then check the phpinfo details if memcache is available. If not, then either install memcache for that php version or don't use memcache in this joomla site.
     
  5. Yes, I confirm what Till says:
    1. Either memcache is not installed on this version of PHP. You can check that in the joomla admin > System info, in the php info tab. Look if you can find memcache in the list of PHP modules. If not, you may be able to install it.
    2. Use the filesystem to handle the cache instead of memcache.
     
  6. onastvar

    onastvar Member

    Thanks that makes sense. Memcache is not installed with PHP 7.1
    How would I disable memcache for this one joomla site? Is doable in Apache Directives?
     
    Last edited: May 27, 2017
  7. I guess you don't have access to the back-end of this site because of memcache problem? If so you can fix this by editing, via FTP, the configuration.php file of this site.
    You should have a line with
    public $cache_handler= 'memcache';​
    and set it to
    public $cache_handler = 'file';​

    You may need to set the permissions on this file to 644 before editing it.
     
  8. onastvar

    onastvar Member

    Thanks Jean-Francois
    I already had tried public $cache_handler = 'file';
    before my post #6,
    didn't really work.

    I tried again and it works now, thank you so much!
     
    Last edited: May 27, 2017
  9. Glad I could help.
     

Share This Page