IspConfig 3.1 and certbot version

Discussion in 'General' started by diablo666, Oct 2, 2016.

  1. diablo666

    diablo666 Active Member HowtoForge Supporter

    I'll thank you again for the great work with ispconfig 3.1, it has become more completed then ever before!

    Now the question, i've seen that during the guide of configuraing server, certbot will be installed manually.

    Now reading the log, i've seen this warning:

    Code:
    certbot.cli:You are running with an old copy of letsencrypt-auto that does not receive updates, and is less reliable than more recent versions. We recommend upgrading to the latest certbot-auto script, or using native OS packages.
    Is it possible to use the certbot package coming with debian/ubuntu instalation instead of the manual installed version?

    Should be this one
    Code:
    Package: certbot
    Versions:
    0.8.1-2~bpo8+1 (/var/lib/apt/lists/http.debian.net_debian_dists_jessie-backports_main_binary-amd64_Packages)
    Description Language:
                     File: /var/lib/apt/lists/http.debian.net_debian_dists_jessie-backports_main_binary-amd64_Packages
                      MD5: deb7e404ce1b150b59379c3f9a73ac1a
    Description Language: en
                     File: /var/lib/apt/lists/http.debian.net_debian_dists_jessie-backports_main_i18n_Translation-en
                      MD5: deb7e404ce1b150b59379c3f9a73ac1a
    
    
    Reverse Depends:
      python-certbot-apache,certbot 0.8.1~
      letsencrypt,certbot
    Dependencies:
    0.8.1-2~bpo8+1 - dialog (0 (null)) python-certbot (5 0.8.1-2~bpo8+1) python (0 (null)) python:any (2 2.7~) python-certbot-apache (0 (null)) python-certbot-doc (0 (null)) letsencrypt (1 0.6.0) letsencrypt (0 (null))
    Provides:
    0.8.1-2~bpo8+1 - letsencrypt
    Reverse Provides:
    
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that should be ok as well.
     
  3. diablo666

    diablo666 Active Member HowtoForge Supporter

    I'll try!

    Thank you!
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    There were no packages at the time we started to work on the letsencrpyt implementation, but I guess I should replace that in the tutorials as well.
     
  5. diablo666

    diablo666 Active Member HowtoForge Supporter

    Very nice, i'll fix also the autoinstall script so.
     
  6. Jesse Norell

    Jesse Norell Active Member

    iirc, ubuntu 16 has a package too
     

Share This Page