ispconfig 3.1.5 - upgrade on slave server

Discussion in 'Installation/Configuration' started by Franz, Oct 12, 2009.

  1. Franz

    Franz Member

    I also try with: ispconfig_update.sh
    here is my install:

    root@server2:/tmp/ispconfig3_install/install# php -q update.php


    --------------------------------------------------------------------------------
    _____ ___________ _____ __ _
    |_ _/ ___| ___ \ / __ \ / _(_)
    | | \ `--.| |_/ / | / \/ ___ _ __ | |_ _ __ _
    | | `--. \ __/ | | / _ \| '_ \| _| |/ _` |
    _| |_/\__/ / | | \__/\ (_) | | | | | | | (_| |
    \___/\____/\_| \____/\___/|_| |_|_| |_|\__, |
    __/ |
    |___/
    --------------------------------------------------------------------------------


    >> Update

    Operating System: Debian Lenny/Sid or compatible

    This application will update ISPConfig 3 on your server.
    MySQL root password []: XXXXXXXXXXX


    Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 157


    :(
    on master server all is OK.
     
  2. damir

    damir New Member

    Hi, pozdrav Franz

    Me as well have the same issue, which you probably saw here: http://www.howtoforge.org/forums/showthread.php?t=40026

    I recived a update script with debug options from Till but i can't test it until tomorrow.

    This seems to be releated to multiserver env. On my master i had no problem but with other two, web and mail im getting the same error message. My DNS servers are separeted from this multi server setup so they are not affected.

    Hope we find some solution soon :)
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    On a multiserver system, you should always update the slaves first and then the master to ensure that you do not get replication errors. With the current update its not that relevant as the database structure has not changed, but for the next updates you should always update the slaves first and then the master.

    @Franz: if you send me a email to dev [at] ispconfig [dot] org, I can send you the debug script too.
     
  4. damir

    damir New Member

    Good to know :), i have another multi server env. that i use for testing purposes, i will try to update slaves first and than master to see if this issue occurs again. Thanx
     
  5. damir

    damir New Member

    Franz or Till, have you guys found any solutions to this update problem?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    No. I'am still working on it. The normal operation of the server should not be affected at the moment as the update stopped before anything was changed. I expect that I will have a solution for it today.
     
  7. Franz

    Franz Member

    i have another issue:
    I create database on slave server, but this is in ispconfig.log:


    13.10.2009-20:38 - DEBUG - Replicated from master: REPLACE INTO web_database (`database_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`type`,`database_name`,`database_user`,`database_password`,`database_charset`,`remote_access`,`remote_ips`,`active`) VALUES ('10','7','5','riud','riud','','3','mysql','c5nekaj','c5nekaj','c5nekaj','','y','','y')
    13.10.2009-20:38 - DEBUG - Call function 'db_insert' in plugin 'mysql_clientdb_plugin' raised by event 'database_insert'.
    13.10.2009-20:38 - ERROR - Unable to connect to the database
    13.10.2009-20:38 - DEBUG - Processed datalog_id 866

    I can not create websate too.
    on master server I can create database.

    how can I try manualy create user on mysql database (ISPconfig way) ?

    and I have table entry in table: web_database on slave server for this database...
    and this entry is also in master database.
    all other entryes are on master only
     
    Last edited: Oct 13, 2009
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    @Franz: Please make new threads for new issues as it might confuse other readers. To your other problem: The mysql root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf is wrong.
     
  9. Franz

    Franz Member

    TNX, Fixed.
     
  10. Franz

    Franz Member

    Today I update with SVN version (as Till sugested, v3.1.6) and all work fine.

    TNX again Till
     
  11. conx

    conx New Member

    hi,

    i got this problem with the salve server too.
    I updated the master frist.

    Frist error in line 157.
    After i saw the post i tried SVN, but i get this Problem:

    Notice: Uninitialized string offset: 0 in /tmp/trunk/install/update.php on line 208

    Fatal error: Cannot use string offset as an array in /tmp/trunk/install/update.php on line 208

    :confused:
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try if this works better on your setup.

    http://www.ispconfig.org/downloads/ISPConfig3-svn-stable.tar.gz

    It might be that the problem caused that some database records were missing on the slave,
    in that case I recommend that you simply copy the ispconfig database over from the master
    to the slave before you run the update. This can be easily done by exporting the db on the
    master with phpmyadmin or the mysqldump commandline application and then reinsert
    the data on the slave. Please make always a backup of the ispconfig database before
    you do any modifications, just to be on the safe side :)
     
  13. damir

    damir New Member

    This is how i did it by instructions from Till:

    Backup salve database first, than export master database and import it on slave. Download 3.0.1.6 svn update and run it, now you should be able to update the slaves.

    Edit: To late from my side, Till answered first :)
     
  14. conx

    conx New Member

    I did update from SVN like you, but still a Problem:

    This application will update ISPConfig 3 on your server.
    MySQL root password []: **pw vom slave** <- hat viele sonderziechen, sollte aber kein problem sein

    MySQL master server hostname [2XX.XXX.XX.X1]:

    MySQL master server root username [root]:

    MySQL master server root password []: **pw vom master**

    MySQL master server database name [dbispconfig]:


    Notice: Uninitialized string offset: 0 in /tmp/ispconfig3_install/install/update.php on line 199

    Fatal error: Cannot use string offset as an array in /tmp/ispconfig3_install/install/update.php on line 199
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    @conx: Please do what I suggested in #12 and copy the database from the master to the slave. It definately works and you will not get this error message anymore.
     

Share This Page