ISPConfig 3.1.2 and Lets Encrypt

Discussion in 'Installation/Configuration' started by toffie, Feb 6, 2018.

  1. toffie

    toffie New Member

    Hey all,
    I just reinstalled one of my servers running ISPConfig and a couple of websites after deleting the symlinks by mistake that resides in /var/www/ ... There are no possibilities to undo that, right? I was tired I guess and pressed enter instead of escape when I pressed the delete button ;)

    Oh well, reinstalled Debian 8 because Debian 9 seems to be too stripped and too cumbersome to configure - even with a perfect server guide!

    So.. I've reinstalled everything, but lets encrypt doesn't want to issue certificates as it did previously.. It doesn't even create the log files.. so right now I have no idea what to do.. Is this an ISPConfig, Linux or Lets Encrypt error?

    I've had so much problems since yesterday, reinstalled Debian 5 times, due to my own failure when installed Debian for Raspberry instead of the regular Debian and then Debian 9 twice and that didn't work out.. so I'm back to Debian 8 and everything else seems to work.

    Any ideas or suggestions to how to go forward?

    Many thanks in advance!
     
    outlook log likes this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. toffie

    toffie New Member

    Awesome till, Thank you! :)
    Let's see..

    - Check that you have Let’s Encrypt installed.
    *** It surely is installed! I've followed the perfect server Debian 8 today :)

    - When your server is behind a NAT router so that the server itself can not reach the hosted domains, then enable the option "Skip Letsencrypt check" under System > Server config > web.
    *** This is not found anywhere under System -> Server config -> web!

    - Check that all domain names (icl auto subdomain www etc), subdomains and aliasdomains really point to the right website and are working. Open one after another in your browser and test that.
    *** All domains/sites work

    - If you still use Apache 2.2, then update your ispconfig to git-stable branch with the ispconfig_update.sh script to get an updated vhost template. After you did that, use Tools > resync to apply the new template to all sites or apply it to a single site by altering a value in the site settings and press save, before you try to activate Let’s Encrypt again. This is only necessary on apache 2.2 systems, newer apache 2.4 or nginx systems are not affected.
    *** Running Apache 2.4

    - If you updated to ISPConfig 3.1 and deselected the "reconfigure services" option during update (which is selected by default), then Let’s Encrypt will fail as your server is missing the Let’s Encrypt configuration in the ispconfig apache configuration files. Redo the update and chose to reconfigure services in that case.
    *** I've updated to latest version and did do the reconfigure services when asked

    Where do I find detailed error messages?

    You can find the log files here: /var/log/letsencrypt - Not found! None are created..
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Attached Files:

    toffie likes this.
  5. toffie

    toffie New Member

    Thanks once again till ! :)
    Apparently I was running 3.1.2 as I wrote in my first message, which obviously isn't the latest version! However, I did think I had upgraded as I reinstalled the server 5 times yesterday and I know I had done the upgrade at some point. Obviously I hadn't done that on this final install ;)

    After the upgrade, now running 3.1.11, I found the skip Lets Encrypt checkbutton and now it seems to work properly right away :)

    I really appreciate your really awesome and quick help and I really hope that this thread could help someone else as well, as well as myself next time I stumble upon this problem which I'm sure I've forgot all about in the next couple of days ;)

    Many Thanks till! :)
     

Share This Page