ISPConfig 3.1.1p1 issue with redirect

Discussion in 'General' started by dfumagalli, Nov 6, 2016.

  1. dfumagalli

    dfumagalli New Member

    Hello,
    I am using Ubuntu 14.04 LTS with Apache as per the "perfect server" setup instructions + Letsencrypt SSL.

    Since years I set "Auto-subdomain" to "www" and it always worked.
    I have noticed, if:
    • I enable Letsencrypt SSL
    • Under Redirect I enable: Rewrite HTTP to HTTPS
    then websites get a proper redirect from http to https, however they lose the www auto-subdomain functionality.

    Example:
    If I enter:

    http://www.rsppfacile.it
    the browser goes to
    https://www.rsppfacile.it

    But if I enter:
    http://rsppfacile.it
    or
    https://rsppfacile.it

    It won't redirect to
    https://www.rsppfacile.it
    but to
    https://rsppfacile.it

    Therefore, auto-subdomain "www" is not being applied.

    Any ideas about what could go wrong?
     
  2. Jesse Norell

    Jesse Norell Active Member

    AFAIK, auto-subdomain just makes the 'www' name available as an alias, it does not perform any redirects. You would need to do that as an SEO redirect, or in the .htaccess of your website, or even in the website sotware (eg. cms) itself.
     
    gOOvER likes this.
  3. dfumagalli

    dfumagalli New Member

    That makes sense, however it does not rationally explain how my non SSL websites perform such redirect without me even knowing I am meant to implement the redirect myself (or by Wordpress).
     
  4. Jesse Norell

    Jesse Norell Active Member

    No, it doesn't :) There are numerous places it can be done, so you'd have to track down what's happening. An additional option is sending a 'Content-Security-Policy: upgrade-insecure-requests' header, and then your browser itself switches to https.
     

Share This Page