ISPConfig 3.1.1p1 - Email problem

Discussion in 'Installation/Configuration' started by Luksor, Nov 10, 2016.

  1. Luksor

    Luksor New Member

    Hello,
    I have installed ISPconfig in version 3.1.1p1 on my dedicated server. I have two domians - luk-tech.net and tlife.pl (the luk-tech.net domian have my own name servers and own dns). Second domian is connected to my own dns created in ovh.net with glue records for luk-tech.net.
    The problem is - I Can't receive mails on luk-tech.net domian. I trying to configure it but in about last week i can't configure it...
    I can send emails from all two domians. But receiving is only in tlife.pl .
    I have default config on second domian, but in first domian i doing all i can to run mail receiving...
    I also add small screenshot with my config from luk-tech.net domian.
    It would be great if someone help me with this...
     

    Attached Files:

    • asd.PNG
      asd.PNG
      File size:
      39.3 KB
      Views:
      10
  2. Jesse Norell

    Jesse Norell Active Member

    In a quick test, mail.luk-tech.net accepts mail to your postmaster address - check your mail log (probably /var/log/mail.log or /var/log/maillog) and see if you find any errors or other indication of what's going on. You could send yourself an email from outside (gmail or something) and post the log results here.
     
  3. Luksor

    Luksor New Member

    Hello, i clear the logs and i send mail from google to my luk-tech.net mail, there is log after few seconds after send mail from gmail.
    Code:
    Nov 10 22:14:49 luk-tech postfix/smtpd[18853]: connect from mail-it0-f45.google.com[209.85.214.45]
    Nov 10 22:14:50 luk-tech postfix/trivial-rewrite[18855]: warning: do not list domain luk-tech.net in BOTH mydestination and virtual_mailbox_domains
    Nov 10 22:14:50 luk-tech postfix/smtpd[18853]: NOQUEUE: filter: RCPT from mail-it0-f45.google.com[209.85.214.45]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-it0-f45.google.com>
    Nov 10 22:14:50 luk-tech postfix/smtpd[18853]: NOQUEUE: filter: RCPT from mail-it0-f45.google.com[209.85.214.45]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-it0-f45.google.com>
    Nov 10 22:14:50 luk-tech postfix/smtpd[18853]: B8AC94BE1537: client=mail-it0-f45.google.com[209.85.214.45]
    Nov 10 22:14:51 luk-tech postfix/cleanup[18860]: B8AC94BE1537: message-id=<[email protected]m>
    Nov 10 22:14:51 luk-tech postfix/qmgr[1878]: B8AC94BE1537: from=<[email protected]>, size=2454, nrcpt=1 (queue active)
    Nov 10 22:14:51 luk-tech postfix/smtpd[18853]: disconnect from mail-it0-f45.google.com[209.85.214.45]
    Nov 10 22:14:51 luk-tech postfix/smtpd[18866]: connect from ipcheck.teamspeak.com[127.0.0.1]
    Nov 10 22:14:51 luk-tech postfix/trivial-rewrite[18855]: warning: do not list domain luk-tech.net in BOTH mydestination and virtual_mailbox_domains
    Nov 10 22:14:51 luk-tech postfix/smtpd[18866]: 5BD484BE1552: client=ipcheck.teamspeak.com[127.0.0.1]
    Nov 10 22:14:51 luk-tech postfix/cleanup[18860]: 5BD484BE1552: message-id=<[email protected]m>
    Nov 10 22:14:51 luk-tech postfix/qmgr[1878]: 5BD484BE1552: from=<[email protected]>, size=2997, nrcpt=1 (queue active)
    Nov 10 22:14:51 luk-tech postfix/trivial-rewrite[18855]: warning: do not list domain luk-tech.net in BOTH mydestination and virtual_mailbox_domains
    Nov 10 22:14:51 luk-tech amavis[18772]: (18772-01) Passed CLEAN {RelayedInbound}, [209.85.214.45]:38876 [209.85.214.45] <[email protected]> -> <[email protected]>, Queue-ID: B8AC94BE1537, Message-ID: <[email protected]m>, mail_id: A08LGZZ_dfAK, Hits: 0.131, size: 2454, queued_as: 5BD484BE1552, dkim_sd=20120113:gmail.com, 323 ms
    Nov 10 22:14:51 luk-tech postfix/smtp[18861]: B8AC94BE1537: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.97, delays=0.64/0/0/0.32, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 5BD484BE1552)
    Nov 10 22:14:51 luk-tech postfix/qmgr[1878]: B8AC94BE1537: removed
    Nov 10 22:14:51 luk-tech postfix/local[18868]: 5BD484BE1552: to=<[email protected]>, relay=local, delay=0.06, delays=0.02/0/0/0.03, dsn=2.0.0, status=sent (delivered to command: procmail -a "$EXTENSION")
    Nov 10 22:14:51 luk-tech postfix/qmgr[1878]: 5BD484BE1552: removed
     
  4. Jesse Norell

    Jesse Norell Active Member

    Remove luk-tech.net from mydestination (in /etc/postfix/main.cf) and try again.
     
  5. Luksor

    Luksor New Member

    I think about it because there are error "
    warning: do not list domain luk-tech.net in BOTH mydestination and virtual_mailbox_domains"
    So i do this what you write in your post and it working now !
    Very thanks to you ! Really, i trying in about two weeks slove this problem and now it's working !
    Thanks !
     

Share This Page