ISPConfig 3.1.15p2 rspamd user spamfilter level configuration

Discussion in 'Installation/Configuration' started by Olivier BOUMATI, Oct 22, 2019.

  1. Olivier BOUMATI

    Olivier BOUMATI New Member

    Hello,

    I replaced amavis with rspamd following the guide: "Replacing Amavisd with Rspamd in ISPConfig 3.1 on Debian and Ubuntu" at https://www.howtoforge.com/replacing-amavisd-with-rspamd-in-ispconfig/
    My server is a Debian 9 under ISPConfig 3.1.15p2

    The antispam filter policy defined in the mail address configuration has the following levels:
    [​IMG]

    This is the policy that is defined in the email account setup page
    [​IMG]

    It is this same strategy that is defined at the domain level
    [​IMG]

    Yet the analysis of rspamd statistics displays a level of 4, as in the screenshot below
    [​IMG]

    Where is this value from ?
    What is the best way to customize the filter levels for an email address?
     
  2. Steini86

    Steini86 Active Member

    Is the first screenshot for the "normal" strat├ęgie?
    In the Rspamd web interface, what values are set in "configuration"?

    I think you have to change something in the mailbox, to rewrite the settings
     
    Last edited: Oct 22, 2019
  3. Olivier BOUMATI

    Olivier BOUMATI New Member

    Yes it is, for the "normal" strategy.
    Next screenshot for the configuration page...
    [​IMG]
    I understand that these are the default settings levels used especially for outgoing mail, is not it?
    I verified all mailboxes configurations and regenerate all configuration files by resyncing with ISPConfig, but my changes seems to be ignored.
    When I change setting levels of strategy or I affects another strategy to a mailbox, the changes are not taken into account, even after the execution of tasks by ISPConfig, I feel that it must restart rspamd with the following command:
    Code:
    service rspamd restart
    Is it normal ?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The screenshot you posted is not from ISPConfig. Use ISPConfig Spamfilter policy settings to change rspamd filter levels as this ensures that the correct levels get applied and that you don't have to restaert rspamd and this also ensures that your settings will not get lost or removed automatically.

    The ISPConfig settings are these ones:

    2019-11-05 16_31_42-ISPConfig.png
     
  5. Olivier BOUMATI

    Olivier BOUMATI New Member

    Sorry, but I answered to Steini86 which asked me for this screenshot.
    Actually, I have not changed those settings.
    I use ISPConfig only to adjust the levels strategies, but what I say is the truth, this is not taken into account.
     
  6. recin

    recin Member

    Till's screenshot and Olivier 1st screen are the same.
    I was to open this same thread coz I created a mail domain and account with spamfilter disabled but rspamd was filtering anyway according to his web interface config.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    That's correct and intended as the defaults of rspamd gets applied if you select no policy, but that's not what this thread is about, the problem discussed here is that he selected a polidy which did not got applied. Please make a new thread next time if you have a question which does not match an existing thread. If you want to get To not filter out emails, select the 'uncensored' policy instead.
     

Share This Page