ispconfig 3.1.12 Mirror not updating nginx vhost or letencrypt

Discussion in 'Installation/Configuration' started by Brett Wilton, Jun 9, 2018.

  1. Brett Wilton

    Brett Wilton Member HowtoForge Supporter

    We have a CentOS 7.5 system that was upgraded from 7.3 and ISPConfig that just got upgrade to 3.1.12 multiserver that is running in master / master mode.

    We just changed the slave server from one machine to another which has a completely different IP range. At the time I didn't realize there was an uninstall so had deleted all secondary ispconfig entries for the old server in ispconfig and delected its ispconfig2 tables.

    I have debug running on both primary and mirror / secondary server. I can see the replication from master events in the ispconfig.log. DNS appears t get updated, mariadb master / master is working correctly, mail is synchronizing, unison is working.

    However the nginx vhost directives do not get updated along with any letsencrypt files. Nginx is compiled and installed manually.

    I'm not sure if the same DEBUG from the primary server should also be generated on the secondary or mirror ?

    No errors seem to be present in either the primary server or secondary server ispconfig.log files.

    Any help on debugging or figuring out why nginx vhost is not updated.

    Top part of htf_report.txt on secondary server is below :-

    ```
    ##### SERVER #####
    IP-address (as per hostname): ***.***.***.***
    [WARN] could not determine server's ip address by ifconfig
    [INFO] ISPConfig is installed.

    ##### ISPCONFIG #####
    ISPConfig version is 3.1.12


    ##### VERSION CHECK #####

    [INFO] php (cli) version is 5.4.16

    ##### PORT CHECK #####

    [WARN] Port 8080 (ISPConfig) seems NOT to be listening
    [WARN] Port 8081 (ISPConfig Apps) seems NOT to be listening
    [WARN] Port 21 (FTP server) seems NOT to be listening
    [WARN] Port 22 (SSH server) seems NOT to be listening

    ##### MAIL SERVER CHECK #####

    [WARN] I found no "submission" entry in your postfix master.cf
    [INFO] this is not critical, but if you want to offer port 587 for smtp connections you have to enable this.

    ##### RUNNING SERVER PROCESSES #####

    [INFO] I found the following web server(s):
    Unknown process (nginx:) (PID 1291)
    [INFO] I found the following mail server(s):
    Postfix (PID 1285)
    [INFO] I found the following pop3 server(s):
    Dovecot (PID 1578)
    [INFO] I found the following imap server(s):
    Dovecot (PID 1578)
    [WARN] I could not determine which ftp server is running.

    ```
     
  2. Brett Wilton

    Brett Wilton Member HowtoForge Supporter

    Additionally this second mirror server seems to have different user and possibly group values (would have to check that again).
    So are wondering if it could be a permission issue however I would have thought some sort of DEBUG entry would appear for that.
     

Share This Page