ISPConfig 3.1.11 with Migration Toolkit 2.0.2

Discussion in 'ISPConfig 3 Priority Support' started by itsolon, Mar 3, 2018.

  1. itsolon

    itsolon New Member HowtoForge Supporter

    i try to migrate my Websites from Plesk Onyx 17.5.3 to ISPConfig new Server.
    Migration Process fails because the tool cannot make new Databse and new Database Users
    here the migration log for you to review

    • howotoforge: the perfect server with debian 9 and nginx step by step - worked
    • then secure admin with letsencrypt - worked
    • lower security in /usr/local/ispconfig/security/security_settings.ini
    Script does move Website data but not databases and throws
    during dry test
    Deprecated: Non-static method IFunctions::byte_to_mbyte() should not be called statically in /root/migration/v56/includes/modules/ on line 336

    [ERROR] API call to sites_database_user_add failed.
    [ERROR] JSON API REPLY ERROR: database_user_error_regex<b$
    - Arguments sent were: array (
    'client_id' => '2',
    'params' =>
    2018-03-03 13:27:50 - [ERROR] API call to sites_database_add failed.
    2018-03-03 13:27:50 - [ERROR] JSON API REPLY ERROR: database_name_error_regex<b$
    - Arguments sent were: array (
    'client_id' => '2',

    E-Mails were not tested due to the reason customer has exchange and no emails on the web.
    Could anyone help me please to get this fixed?
    The Question is: why do i need a Migration tool when automated Migration doesnt work?

    After That: the website is "offline" 502 nginx until manual reboot

    Best regards
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That the migration stopped on your server does not mean that there is a general problem with migrations or the migration tool. According to the error you posted, the database name of the database is not allowed in ISPConfig, so your problem is not related to the migration tool directly. The tool just shows you the error that ISPonfig has thrown when the tool tried to insert the database, you would have received the exact same error when you would have added a database with that name manually.

    You did not post the actualy database name, so I can't tell you why it got rejected.
  3. itsolon

    itsolon New Member HowtoForge Supporter

    Your answer was quite helpful, i will tell you why.
    the database name of the database is not allowed
    without having tested it i assume that i made following mistake.
    i have same name for database name and database user... thats probably not very good?
    i try to alter that on the source server and then perhaps it runs through?
    do i have to reinstall the server and ispconfig new, or is there any possibility to try

    Thank you very much for your fast and friendly anser, i was surprised to get so fast replies on my posts from you.

    Have a good evening i will update this thread when i made my experience with the program.

    One thing i can say on this point of my discovery ... its much much much faster than the other server with plesk, this means lightweight and close to standard installations .. i dont know how to explain it better in english.

    For example, in last month when i discovered problems with my Plesk Installation and wanted to know something then i did not get useful answers and not in this short time too.
    Every Code-"Schnipsel" found on the Internet i could not apply because it does not work for Plesk.

    In Short, Admin-Panels can simplify your life but some of them do the opposite.
    I think that ISPConfig does best..

    Please excuse the unfriendly question on the end of my initial post.
    Best regards
    till likes this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Using the same name for a database user and the database should be fine, but ISPConfig restricts the names to just contain: the characters: a-z, 0-9 and underscore and the length should be between 2 and 62 chars if I remember correctly. If your database name or user contains other chars, then you'll either have to change the name of the database or user or you'll have to alter the regular expression in the ISPConfig sourcecode to allow that char.

    A reinstallation should not be nescessary. If the ISPConfig interface is accessible on the new server, then just run the migration again. In cae that iT's inacessible, then the cause can only be a partly written website config that prevents the web server to start. In that case, go to the sites-enabled folder (this is e.g. /etc/apache2/sites-enabled/ or /etc/httpd/conf/sites-enabled/ or /etc/nginx/sites-enabled/), this flder contains symlinks to all vhost files, remove all symlinks except of the ones that start with 000- in their name, then restart apache or nginx (depends on your setup) and the ispconfig interface should be up aain. If not, then you can do an ispconfig update (choose git-stable as source when it says that there is no update) and let it rewrite the config files.

    Yes, thats what we try to achieve with ISPConfig. an ISPConfig server uses the packages of the chosen Linux distribution and we try to use the standard config directories were possible. So basically any info that you find e.g. about a standard Debian setup applies to a Debian ISPConfig server as well and another benefit is that you get security updates for all software right from the Linux distribution.
  5. itsolon

    itsolon New Member HowtoForge Supporter

    ok.. no following nex issue during installation:
    i have successfully migrated from plesk onyx to ispconfig 3.1.11 stable
    with following warning:
    2018-03-05 09:57:32 - [WARN] storeProtectedFolderUser: Could not resolve for folderuser to new client id.
    it seems that all databases have migrated, but the correlation from database user to database is unset.. can set it manually after migration
    is this warning important?
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    The protectedFolderUser warning is not important (if it is the only warning).
    The correlation between db and db user should have been set. Could you please send us the migrate.log to [email protected]?
  7. itsolon

    itsolon New Member HowtoForge Supporter

    After some good support from Mr. Burkard i got this to run finally. Fully satisfied. thank you for that.

Share This Page