ISPConfig 3.05 and owncloud 5.0.10 - Permissions?

Discussion in 'Installation/Configuration' started by ichesseschimmel, Aug 25, 2013.

  1. ichesseschimmel

    ichesseschimmel New Member

    Hi

    Does someone know how to install owncloud 5.0.10 under Ubuntu 13.04 with ISPConfig 3.05?

    I tried it several times without success.

    I installed it with apt-get
    (see: http://software.opensuse.org/download/package?project=isv:ownCloud:community&package=owncloud)

    Now its in my /var/www folder. But I need it in a clients web folder (e.g. /var/www/clients/client1/web1/owncloud)

    If i try to mv it as root it get: Permission denied

    Anyhow. I tried also to install it manually:
    -downloaded the files
    -put them into clients web folder
    -chown to right user and group
    -chmod

    Result: Either 500 (I guess because of .htaccess - also with this I had no success) or 403 ....

    And the funny part: It was working... I just updated to owncloud v5 via the web updater and BAM 500.

    What else can I do?

    thx

    p.s.:

    some additional information:

    ISP Server Config:

    .htaccess AllowOverride all



    Set folder permissions on update false
    Make web folders immutable (extended attributes) true
    Add web users to -sshusers- group true
    Connect Linux userid to webid false
    Start ID for userid/webid connect 10000
     
    Last edited: Aug 25, 2013
  2. Franz

    Franz Member

    I use ISP config with debian 6 and owncloud and everything is working fine


    try to upload owncloud files via FTP.
     
  3. tahunasky

    tahunasky New Member

    I have owncloud running with Ubuntu 13.04 with ISPConfig 3.05:
    I put extra apps into the /opt directory. I use /var/owncloud for data.

    I would suggest deleting all previous installations, then as root:

    cd /tmp
    wget http://download.owncloud.org/community/owncloud-5.0.10.tar.bz2
    tar -xjf owncloud-5.0.10.tar.bz2
    cp -r owncloud /opt
    mkdir /var/owncloud
    mkdir /var/owncloud/data
    chown -R www-data:www-data /var/owncloud/data
    chown -R www-data:www-data /opt/owncloud/config/
    chown -R www-data:www-data /opt/owncloud/apps/
    ln -s /var/owncloud/data /opt/owncloud/data

    Create an apache config file with permissions and redirections:
    #/etc/apache2/conf.d/owncloud.conf
    Code:
    Alias /cloud /opt/owncloud
    Alias /owncloud /opt/owncloud
    
    <Directory /opt/owncloud>
       Options +FollowSymLinks
       Order allow,deny
       allow from all
    
       RewriteEngine  on
       RewriteCond    %{HTTPS} !=on
       RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    </Directory>
    

    Change the /etc/php5/php.ini or .htaccess file to increase upload file size:
    Code:
    upload_max_filesize = 500 MB
    post_max_size = 600 MB
    I also have cloud as a subdomain (eg: cloud.mydomain.com) for all domains hosted on my servers - using HTTPS. I do this by:
    create /etc/apache2/sites-available/cloud.vhost

    Code:
    <VirtualHost *:80>
    	ServerName cloud.mydomain.com
    	ServerAlias cloud.*
    
    	RewriteEngine  on
    	RewriteCond    %{HTTPS} !=on
    	RewriteRule (.*) https://%{HTTP_HOST}
    </VirtualHost>
    
    <VirtualHost *:443>
    	ServerName cloud.mydomain.com
    	ServerAlias cloud.* 
    	DocumentRoot /opt/owncloud
    	ServerAdmin [email protected]
    
    	SSLEngine On
    	SSLCertificateFile /etc/ssl/mydomain.com/server.crt
    	SSLCertificateKeyFile /etc/ssl/mydomain.com/server.key
    	ErrorLog /var/log/apache2/owncloud-error_log
    	CustomLog /var/log/apache2/owncloud-access_log common
    
    	<Directory /opt/owncloud>
    		Options +FollowSymLinks
    		Order allow,deny
    		allow from all
    	</Directory>
    
    </VirtualHost>
    
    then create a link to it:

    ln -s /etc/apache2/sites-enabled/001-cloud.vhost /etc/apache2/sites-available/cloud.vhost

    and finally restart apache.
    /etc/init.d/apache2 restart
     
    Last edited: Aug 26, 2013
  4. ichesseschimmel

    ichesseschimmel New Member

    thanks for the help.
    still dosen't work (internal server error 500)

    cant find anything in the logs...

    any suggestions?
     

Share This Page