ISPConfig 3.0.5 released

Discussion in 'General' started by till, Feb 25, 2013.

  1. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No need to downgrade ispconfig, the problem is just that your dovecot install seems to be missing a module which is now used in current ispconfig versions. Just copy the /etc/dovecot/dovecot.conf file from the etc backup in /var/backups/ to your current install and restart dovecot.
     
  2. cbj4074

    cbj4074 Member HowtoForge Supporter

    Okay, that approach to selecting the correct configuration template seems very reasonable.

    The output of "dovecot --version" is:

    Code:
    1.2.9
    
    Line 685 of /etc/dovecot/dovecot.conf contains:

    Code:
      sieve=~/.dovecot.sieve
    
    Doesn't this need to go inside the plugins {} stanza? My old configuration file has:

    Code:
    plugin {
        sieve=/var/vmail/%d/%n/.sieve
    }
    
    In the new file, this directive is inside a different stanza:

    Code:
    protocol managesieve {
      sieve=~/.dovecot.sieve
    }
    
    Or are these two different entities?

    Thanks!
     
    Last edited: Feb 27, 2013
  3. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    @cbj4074

    This might be different settings, one global and one for the plugin scope. Which Linux Distribution & version do you use so that I can try to verify the problem?
     
  4. cbj4074

    cbj4074 Member HowtoForge Supporter

    Thanks for the prompt replies, Till.

    I'm on Ubuntu 10.04 and installed Dovecot from the OS's repository.
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok,I will setup a test system with this version tomorrow. Till then you should be able to use your old dovecot.conf file, it should be compatible with ispconfig 3.0.5.
     
  6. cbj4074

    cbj4074 Member HowtoForge Supporter

    Thanks, Till. I really appreciate you going to all the trouble.

    I performed additional research and in my old configuration, the term "sieve" only appears in two places:

    Code:
    protocol lda {
      mail_plugins = sieve quota
    }
    
    [...]
    
    plugin {
      sieve=/var/vmail/%d/%n/.sieve
    }
    
    Yet, in the new configuration that ISPC 3.0.5 created, there are a number of new stanzas and directives that weren't there before, and one of them contains the line that causes the fatal error during Dovecot start-up:

    Code:
    protocol managesieve {
      # This is the line that causes the fatal error.
      sieve=~/.dovecot.sieve
      
      sieve_storage=~/sieve
    }
    
    Is the problem, in essence, the presence of the protocol managesieve block? I have dovecot-pigeonhole installed, but I've never had any reference to it (or managesieve) in my Dovecot configuration file.

    To help you reproduce this situation on your own VM:

    Code:
    # dpkg --list | grep dovecot
    ii  dovecot-antispam                 1.2+20090702-1ubuntu0.10.04.1 a Dovecot plugin that helps train spam filte
    ii  dovecot-common                   1:1.2.9-1ubuntu6.5            secure mail server that supports mbox and ma
    ii  dovecot-imapd                    1:1.2.9-1ubuntu6.5            secure IMAP server that supports mbox and ma
    rc  dovecot-pigeonhole               0.3.1-3~rns~lucid             secure mail server - sieve and managesieve s
    ii  dovecot-pop3d                    1:1.2.9-1ubuntu6.5            secure POP3 server that supports mbox and ma
    
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The managesieve config syntax seems to have changed between dovecot 1.1 and 1.2

    http://wiki.dovecot.org/ManageSieve/Configuration

    Maybe we should disable managesieve for dovecot 1.x again as it was in 3.0.4.6, if somebody needs it he can enable it in his own config. iSPConfig has different config file sets only for dovecot 1.x and 2.x and it des not make much sense to start a new set for a old dovecot version just to have managesieve on by default.
     
  8. contremaitre

    contremaitre New Member

    i did a smooth upgrade from 3.0.4.6 on a multi server setup. but my global search function is the only thing not working. am i missing something?

    let me know guys

    thanks :)
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Try to empty the browser cache and reload the page. If you use a custom theme, then you might have to extend it for the global search.
     
  10. contremaitre

    contremaitre New Member

    using the default theme for ISPConfig, as well this reproduces on all my devices and browsers regardless of cache.
    Let me know.

    Thanks
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The global search works fine for me, You can verify it in the online demo:

    http://demo3.ispconfig.org/index.php

    user: admin
    password: demo

    then type in the saerch field the word "test" and it will show you all records matching this word. Please note that the min. number of chars is 4 chars.
     
  12. zbuzanic

    zbuzanic New Member

    Upgrade went fine, all services are ok.
    I see theme was drastically changed, still you should work on CSS, for me it looks really messy but I've managed to find my way :)

    Anyway I have one problem with DNS zones, if I open current zones and try to add new records I get this:
    [​IMG]

    Also, consider translating "Powered by" in main.tpl.htm ;)

    Does new manual contains how to add different PHP versions and how to fire up appstandard since I don't see it?

    Thank you for your great work!
     
  13. contremaitre

    contremaitre New Member

    i know :(
    although mine doesnt work lol.
    you can see a slight underline as if its trying to come out but doesnt.
    reproduces for me in every browser on multiple os so i know its not a cache thing.
    i guess i have to do a clean install to have everything work as it should :)
     
  14. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Remove the whitespace from the two fields between the ip addresses.

    This is part of the installation tutorials (perfects etup guides) and not the manual. See e.g. chapter 14.3 here: http://www.howtoforge.com/perfect-server-ubuntu-12.10-apache2-bind-dovecot-ispconfig-3-p4

    ISPConfig 3.0.5 manual, chapter "4.6.5 APS Installer"
     
    Last edited: Feb 28, 2013
  15. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Do you use the default theme? Is the sarch string you used londer then 4 chars and are you sure that there is a record for that in the ispconfig database?
     
  16. Friendbg

    Friendbg New Member

    Hello, thanks for the great product and for the update! I have strange question. Yesterday I install the latest version of ISPconfig on ubuntu 12.10 on vmware and try to update Aps & Addons and it shows a lot of apps. Today I install the same version of ubuntu and ISPconfig on openvz host and try to update apps and addons again and nothing shows this time. Is there any apps on http://repo.ispconfig.org/addons/ or yesterday there was a bug? Thanks
     
  17. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    I guess you mix up the APS installer of the sites module with the ISPConfig extension installer in the System module. The ispconfig extension installer has no extensions at the moment while there are lots of apps in the APS installer of the site module.
     
  18. Friendbg

    Friendbg New Member

    Till , sorry bro , my mistake :) Thanks! Great product!
     
  19. zbuzanic

    zbuzanic New Member

    Interesting, but this (whitespace) is ignored on Secondary DNS.

    Also, are we able to add secondary zone via DNS template now or it's still manual work?
     
  20. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thanks for reporting this, we will fix the missing check in the secondary record.

    The wizard is fro primary records only. if you use ispconfig for primary and secondary dns, then no secondary records have to be created.
     

Share This Page