ISPConfig 3.0.5 RC 1 released for testing

Discussion in 'Developers' Forum' started by till, Dec 21, 2012.

  1. till

    till Super Moderator

    The release candidate (RC) of the upcoming ISPConfig 3.0.5 is available for download. RC versions are released for testing purposes and should not be installed on production systems.

    What's new in ISPConfig 3.0.5

    - APS package installer. See http://www.apsstandard.org for a list of available packages.
    - New web backup system which includes the website databases.
    - Mailuser login.
    - PHP version selector. Use different PHP versions for different websites.
    - Subdomains as virtualhost with separate directory inside the directory tree of the main website without rewriting.
    - Support for mod_perl2.
    - Improved default theme.
    - Global search function.
    - PHP-FPM support for Apache servers.
    - PHP-FPM mode selector in website options.
    - Hardened the website folder structure with new folder protection feature and stricter security settings.
    - Maintenance mode.
    - Password generator.
    - Password confirmation fields.
    - Directive snippets for Apache, nginx, and PHP can now be saved and be reused for other websites.
    - Forms can be submitted by pressing ENTER (you don't have to click the Save button anymore).
    - Many more minor feature enhancements and bugfixes.
    - IDN domains are converted automatically to / from punicode. (requires PHP idn extension from pecl)
    - Mail traffic reporting for dovecot servers.

    Special thanks to Marius Cramer from www.pixcept.de for his contributions to the 3.0.5 ISPConfig release.

    Detailed Changelog

    http://bugtracker.ispconfig.org/index.php?do=index&tasks=&project=3&due=45&status[]=

    Download

    http://www.ispconfig.org/downloads/ISPConfig-3.0.5-rc1.tar.gz

    Update instructions

    Code:
    cd /tmp
    rm -rf /tmp/ispconfig3_install
    wget http://www.ispconfig.org/downloads/ISPConfig-3.0.5-rc1.tar.gz
    tar xvfz ISPConfig-3.0.5-rc1.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    
     
  2. Petr

    Petr New Member

    Hi, I have a small question about APS installation .

    is OK this work?

    1)
    if I have installed one APS in mydomain.ltd/aps1 and new instaled second aps on root ( mydomains.ltd ) - this action remove APS in mydomain.ltd/aps1 too .

    2)
    I have installed one APS on mydomains.ltd and second in mydomain.ltd/aps1 and remove APS in root ( mydomains.ltd ) - this action remove all APS .

    all action install/uninstall I do on APS option page.

    thanks, Petr
     
  3. till

    till Super Moderator

    This can happen when you install more then one package per website depending on the packagees, file and folder names etc. I will see if we add a option that the admin can disable the ability to install more then one package per site.
     
  4. renaudmanda

    renaudmanda New Member

    APS Installer failed

    I tried to use the installer to install wordpress 3.5 to the root of a website.

    Unfortunately I got "installation_error". When I check in the error.log file I see that wp-load.php tries to access to /var/www/<website>/wp-config.php file instead of /var/www/<website>/web/wp-config.php

    Is it an aps installer error or something missconfig on my side ? Where can I check APS installer logs ?

    Regards,
    Renaud
     
  5. till

    till Super Moderator

    I had tested the wordpress install last week and it worked fine at that time. What did you enter into the path field?

    The aps installer has no separate log. See sticky post in thegeneral forum for debug instructions.
     
  6. renaudmanda

    renaudmanda New Member

    I left it empty, because I wanted to install WP at the root.

    So in Basic settings on the "Install location" line I had:

    Installation location http(s)://<website fqdn> / <field empty>

    Renaud
     
  7. till

    till Super Moderator

    Thats ok, these are the settings I tested before the RC was released. So maybe the aps package from apsstandard.org was updated or is broken at the moment.
     
  8. gjm31

    gjm31 New Member

    mine was working fine until update, update completed, now internal server error when trying to connect to ispconfig.

    Running centos 6.3 with apache , courier etc.

    All working fine as said, but no after update
     
  9. gjm31

    gjm31 New Member

    heres my server log ;

    [Sat Dec 29 12:59:07 2012] [warn] [client 192.168.1.4] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Sat Dec 29 12:59:07 2012] [error] [client 192.168.1.4] Premature end of script headers: index.php

    So the problem is fastcgi, and im not sure how to fix it?
     
  10. till

    till Super Moderator

    Check that the path to the php cgi binary in the file /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter is correct.
     
  11. gjm31

    gjm31 New Member

    It was wrong, however corrected it, restarted httpd, still same errors.

    How would simply updating from 3.0.4 to 3.0.5rc1 break it ?
     
  12. gjm31

    gjm31 New Member

    [root@centos httpd]# cat /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    #!/bin/sh
    PHPRC=/etc/
    export PHPRC
    export PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_CHILDREN=1
    exec /usr/bin/php -d magic_quotes_gpc=off -d session.save_path=/usr/local/ispconfig/server/temp
    [root@centos httpd]# whereis php
    php: /usr/bin/php /etc/php.ini /etc/php.d /usr/lib64/php /usr/include/php /usr/share/php /usr/share/man/man1/php.1.gz
    [root@centos httpd]#
     
  13. till

    till Super Moderator

    The php fastcgi binary does not nescessarily has the name "php", on most distributions it is nmed php-cgi or php5-cgi while the binary with the name "php" is just the php cli version.

    Did you install our server exactly as described in the perfect setup guide?
     
  14. gjm31

    gjm31 New Member

    Still no luck here.

    And yes installed it exact, and as said, worked fine on 3.0.4, but the update to 3.0.5rc1 has totally broken it :(
     
  15. gjm31

    gjm31 New Member

    [root@centos httpd]# cat /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
    #!/bin/sh
    PHPRC=/etc/
    export PHPRC
    export PHP_FCGI_MAX_REQUESTS=5000
    export PHP_FCGI_CHILDREN=1
    exec /usr/bin/php-cgi -d magic_quotes_gpc=off -d session.save_path=/usr/local/ispconfig/server/temp
    [root@centos httpd]#

    [root@centos httpd]# whereis php-cgi
    php-cgi: /usr/bin/php-cgi
    [root@centos httpd]#

    [Sun Dec 30 17:21:45 2012] [warn] [client 192.168.1.4] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [Sun Dec 30 17:21:45 2012] [error] [client 192.168.1.4] Premature end of script headers: index.php
     
  16. till

    till Super Moderator

    Did you restart apache? A reload is not enough!
     
  17. gjm31

    gjm31 New Member

    yes :(

    did a restart of apache, and still same problems, just really dont get how 3.0.4 would work and now 3.0.5 doing this?
     
  18. till

    till Super Moderator

    Thousands of lines of code have been changed or added and the new setup is stricter and more secure, so this can lead to problems. We did not had such a problem in our tests, I will add your problem to our bugtracker so we can test it on centos 6.3 again.

    What you can do as a workaround is to edit the /etc/httpd/sites-enabled/000-ispconfig.vhost file and remove the # in fron of the line:

    # <IfModule mod_php5.c>

    until:

    # </IfModule>

    and restart apache.
     
  19. Typhon

    Typhon New Member

    This version seems to complete everything he failed to ISPConfig
    This is perfect!
    However I have some suggestions:
    Major security problems :
    -Check if the mail you want use is not already used by another
    -Secure domain-management, because right now we can use any domain name that is well configured or not and the most important is that you can use the domain name of the other clients, even that is the domain of the host causing a problem with the security (easy Fishing for every one !)
    -So there is a very big problem: If a client makes a false certificate SS ... all the server (apache) crash! and without exception! Without exception!
    It was all i think..
     
  20. till

    till Super Moderator

    This is a configuration issue in your install and not a security issue as ispconfig has functions to protect you against this. The function is named domain limit. Go to System > Interface > Main config and enable the checkbox "Use the domain limits in client module to add new domains" to enable the domain limit function.

    The domain limit function is visible then in the left menu of the client module.

    This problem existed in 3.0.4.6 as apache is not able to skip malformed ssl certificates. It has been solved in 3.0.5 by including the ssl configuration part into the config rollback, so a client can not crahs apache anymore as ispconfig will use the last working configuration or ssl certificate.
     

Share This Page