ISPConfig 3.0.5.4p3 Can't Access Server Config (Error)

Discussion in 'Installation/Configuration' started by Stu, Aug 15, 2014.

  1. Stu

    Stu New Member

    Hello,

    I just updated to ISPConfig 3.0.5.4p3 (previous version I had been using was 3.0.5.4p1).

    I am now unable to access "Server Config" and "Main Config" (both under the "System" tab).

    When I click either of the two, I get the following error:
    Code:
    Error
    
        Check for security permission: admin_allow_server_config failed.
    The reason I'd like to access "Server Config" is because after updating, I can no longer access the SSL version of PhpMyAdmin (but I can access the non-SSL version). The way I originally enabled SSL access was by doing the following:
    Now when I try going to https://domain.com:8081/phpmyadmin/, I get the following:
    Code:
    Secure Connection Failed
    
    An error occurred during a connection to domain.com:8081. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)
    
        The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
        Please contact the website owners to inform them of this problem. Alternatively, use the command found in the help menu to report this broken site.
    Two things to note:
    1. When updating using ispconfig_update.sh, for "Reconfigure Services" I mistakenly selected "yes" rather than "no".
    2. I successfully protected the ISPConfig Interface with .htaccess by running the following command:
      Code:
      php /usr/local/ispconfig/server/scripts/ispconfig_htaccess.php
      
      ...and editing the file /etc/nginx/sites-available/ispconfig.vhost, adding the following lines right after line 35's "fastcgi_temp_file_write_size 256k;":
      Code:
      auth_basic "Members Only";
      auth_basic_user_file /usr/local/ispconfig/interface/.htpasswd;

    My server is running Nginx 1.4.6 under Ubuntu 14.04.1 LTS.

    I'd appreciate any help with this.

    Thanks, and ISPConfig is simply awesome!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you logged in as main admin (userid 1) into ispconfig?
     
  3. Stu

    Stu New Member

    Thanks for the speedy reply.

    No, I am not logged in as admin (userid 1). I have long since disabled admin (userid 1) and instead have an alternate admin name with a different user id.

    I just now tried re-enabling admin (userid1) (I didn't previously delete this user, but rather disabled it); however, I get the following error:
    Code:
    Error
    
        Check for security permission: admin_allow_new_admin failed.
    I will try to re-enable admin (userid 1) in the actual database and see if it works.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please seee relaese notes about new security settings:

    http://www.howtoforge.com/forums/showthread.php?t=66655

    by default, sib admins dont have the permission to alter many settings anymore to make the system more secure. you can change that in the security_settings.ini.
     
  5. Stu

    Stu New Member

    Thanks! I can now access "Server Config".

    In the file /usr/local/ispconfig/security/security_settings.ini, I changed "admin_allow_server_config=superadmin" to "admin_allow_server_config=yes"

    I noticed I had to re-enter the "Apps-vhost Domain" value within System -> Server Config -> Web -> Apps Vhost Settings, and now I can once again access the SSL version of PhpMyAdmin.

    Thanks again!
     
    Last edited: Aug 15, 2014
  6. iandoug

    iandoug New Member

    Likewise, I have also long since disabled userid 1, since it is far too easy to guess. It would be nice if the available options were superuser/yes/no/[username] where username was the username of the real superuser...

    thanks, Ian
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You can change the username of the admin user to anything you like, so nobody can guess it.
     
  8. HaveANiceDay

    HaveANiceDay New Member

    Hi.
    I have encountered this problem after upgrading, I can not change any settings. I go through the administrator account (userid 1, sys_userid 1, sys_groupid 0, username admin). In the configuration file, I tried to change the values on everything possible, it had no effect.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that mod_fcgi is installed and enabled in apache and that php-cgi is installed as well. suexec should be enabled in apache as well.
     
  10. HaveANiceDay

    HaveANiceDay New Member

    Hi Till,
    I use a bundle Nginx+ php-fpm. Apache servise is stop.
     

Share This Page